summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Gralinski2022-01-22 13:15:46 +0100
committerFilip Gralinski2022-01-22 13:15:46 +0100
commitd53831445784494590cee6833fde3ff45f680950 (patch)
tree33c1e1091d8a7b961662a8f13518aab0f9d14fe7
downloadaur-python-natlibpy.tar.gz
Init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd5b58d59f60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-natlibpy
+ pkgdesc = Code Nathan Arthur finds reusing often
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/narthur/natlibpy
+ arch = any
+ license = MIT
+ depends = python
+ source = https://files.pythonhosted.org/packages/e8/af/8628717473ea934dce7179f01153ca687aa8ef7280dd8623418f1e6977fd/natlibpy-1.0.0.tar.gz
+ sha256sums = ea03a797968d355e8d7db7caf912d982e12824d99c31fed255c932fdb7b12bae
+
+pkgname = python-natlibpy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b535710143cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Filip Gralinski <filipg@amu.edu.pl>
+
+_name=natlibpy
+pkgname=python-${_name}
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Code Nathan Arthur finds reusing often"
+arch=('any')
+url="https://github.com/narthur/natlibpy"
+license=('MIT')
+depends=('python')
+source=("https://files.pythonhosted.org/packages/e8/af/8628717473ea934dce7179f01153ca687aa8ef7280dd8623418f1e6977fd/${_name}-${pkgver}.tar.gz")
+sha256sums=('ea03a797968d355e8d7db7caf912d982e12824d99c31fed255c932fdb7b12bae')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+}