summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-12-19 22:38:06 -0500
committerCarlos Aznarán2023-12-19 22:38:06 -0500
commit389ca9e4b5aef657ca3a5841cb4316862824f5fe (patch)
tree082f2b2aa73ec92ca5cc289c4645b55c98d7956b
parent995332a6535c2048bcb4e266ea97408918250999 (diff)
downloadaur-python-niapy.tar.gz
Bump version to 2.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7825c8ce432e..90e53da435a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python-niapy
- pkgdesc = Python microframework for building nature-inspired algorithms
- pkgver = 2.0.5
+ pkgdesc = Python micro framework for building nature-inspired algorithms
+ pkgver = 2.1.0
pkgrel = 1
url = https://NiaPy.org
arch = any
license = MIT
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry-core
depends = python-pandas
depends = python-matplotlib
- depends = python-openpyxl
- source = NiaPy-2.0.5.tar.gz::https://github.com/NiaOrg/NiaPy/archive/2.0.5.tar.gz
- sha512sums = 371aa8237c0b821ffb07bc12a2e9def1bcedce2ac8d217bd41eda5a792ffa386bea3be8d52b1db304b6706fa9d4e8fe93e44e7ab93b58374ba78cde40f95b34d
+ source = NiaPy-2.1.0.tar.gz::https://github.com/NiaOrg/NiaPy/archive/2.1.0.tar.gz
+ sha512sums = d877a0b70ce7bf6208593d08f3f7bd4819a663e3fd3dcae57473ceef1505cf1a881ee82a7e92ebc153d8044df959800110c9915641668c90ebd9bee30fef591e
pkgname = python-niapy
diff --git a/PKGBUILD b/PKGBUILD
index ed87c24329e2..0dbd9c93e9cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,32 @@
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
_base=NiaPy
pkgname=python-${_base,,}
-pkgver=2.0.5
+pkgver=2.1.0
pkgrel=1
-pkgdesc="Python microframework for building nature-inspired algorithms"
+pkgdesc="Python micro framework for building nature-inspired algorithms"
url="https://${_base}.org"
arch=(any)
license=(MIT)
-depends=(python-pandas python-matplotlib python-openpyxl)
+depends=(python-pandas python-matplotlib)
+makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::https://github.com/NiaOrg/${_base}/archive/${pkgver}.tar.gz)
-sha512sums=('371aa8237c0b821ffb07bc12a2e9def1bcedce2ac8d217bd41eda5a792ffa386bea3be8d52b1db304b6706fa9d4e8fe93e44e7ab93b58374ba78cde40f95b34d')
+sha512sums=('d877a0b70ce7bf6208593d08f3f7bd4819a663e3fd3dcae57473ceef1505cf1a881ee82a7e92ebc153d8044df959800110c9915641668c90ebd9bee30fef591e')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
cd ${_base}-${pkgver}
- python -m pytest
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}