summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasoud2016-12-02 12:45:14 +0100
committerMasoud2016-12-02 12:45:14 +0100
commit5241c7ac58fa3a01be91ec137d7fbb6f04639372 (patch)
tree9b63d1036047d1e96f32ee5ce742b553bf7dfac8
parent80569c3b31edc0b78c0c879ad39e2ab2422510fb (diff)
downloadaur-5241c7ac58fa3a01be91ec137d7fbb6f04639372.tar.gz
fixed dependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb28c3eeaa83..baee98cd5b73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = python-nibabel
pkgdesc = Python library for reading and writing of some common neuroimaging file formats
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = http://nipy.org/nibabel
arch = i686
arch = x86_64
- license = BSD
+ license = MIT
makedepends = python-setuptools
+ makedepends = python-nose
+ makedepends = python-mock
depends = python
- source = https://pypi.python.org/packages/source/n/nibabel/nibabel-2.0.0.tar.gz
- md5sums = befa2fcbd242496a83007a47aad538de
+ depends = python-numpy>=1.5
+ optdepends = python-scipy: for full SPM-ANALYZE support
+ optdepends = python-pydicom>=0.9.7: for DICOM support
+ optdepends = python-pillow: for PNG conversion in DICOMFS
+ source = https://github.com/nipy/nibabel/archive/2.1.0.tar.gz
+ md5sums = f6e213894939aece4619e3a45259dfbd
pkgname = python-nibabel
diff --git a/PKGBUILD b/PKGBUILD
index 08de29bb4566..7ac40367bc1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: Masoud <mpoloton@gmail.com>
-pkgname=('python-nibabel')
+pkgname=python-nibabel
pkgver=2.1.0
pkgrel=1
-pkgdesc="Python library for reading and writing of some common neuroimaging file formats"
+pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
arch=('i686' 'x86_64')
url="http://nipy.org/nibabel"
license=('MIT')
+
depends=( 'python'
- 'python-numpy>=1.5'
- 'python-scipy'
- 'python-pillow'
- 'python-pydicom' )
+ 'python-numpy>=1.5' )
+
+optdepends=( 'python-scipy: for full SPM-ANALYZE support'
+ 'python-pydicom>=0.9.7: for DICOM support'
+ 'python-pillow: for PNG conversion in DICOMFS' )
+
makedepends=('python-setuptools' 'python-nose' 'python-mock')
source=("https://github.com/nipy/nibabel/archive/${pkgver}.tar.gz")
md5sums=('f6e213894939aece4619e3a45259dfbd')