summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwedjat2018-03-13 22:13:36 +0100
committerwedjat2018-03-13 22:13:36 +0100
commit76c93744b6a8f0b5d65317a2145122bb5439310e (patch)
treede7c62ba4c8db3e5af52d4d79f5a4945867df419
parent5241c7ac58fa3a01be91ec137d7fbb6f04639372 (diff)
downloadaur-76c93744b6a8f0b5d65317a2145122bb5439310e.tar.gz
New maintainer; update to version 2.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD53
3 files changed, 37 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baee98cd5b73..8e3791c33e7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = python-nibabel
pkgdesc = Python library for reading and writing of some common neuroimaging file formats
- pkgver = 2.1.0
+ pkgver = 2.2.1
pkgrel = 1
- url = http://nipy.org/nibabel
- arch = i686
+ url = http://nipy.org/nibabel/index.html
arch = x86_64
license = MIT
+ license = BSD
makedepends = python-setuptools
- makedepends = python-nose
- makedepends = python-mock
depends = python
- depends = python-numpy>=1.5
+ depends = python-numpy>=1.7.1
+ depends = python-six>=1.3
optdepends = python-scipy: for full SPM-ANALYZE support
optdepends = python-pydicom>=0.9.7: for DICOM support
optdepends = python-pillow: for PNG conversion in DICOMFS
- source = https://github.com/nipy/nibabel/archive/2.1.0.tar.gz
- md5sums = f6e213894939aece4619e3a45259dfbd
+ optdepends = python-indexed-gzip
+ source = python-nibabel-2.2.1.tar.gz::https://github.com/nipy/nibabel/archive/2.2.1.tar.gz
+ md5sums = 92a9d5d3d5de6bfb8754f8e4ba310e2d
pkgname = python-nibabel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6a43a19d07d5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*tar.gz
+*pkg.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 7ac40367bc1c..f6686dded09b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
-# Maintainer: Masoud <mpoloton@gmail.com>
+# Maintainer: wedjat <wedjat@protonmail.com>
+# Contributor: Masoud <mpoloton@gmail.com>
pkgname=python-nibabel
-pkgver=2.1.0
+pkgver=2.2.1
pkgrel=1
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
-arch=('i686' 'x86_64')
-url="http://nipy.org/nibabel"
-license=('MIT')
-
-depends=( 'python'
- 'python-numpy>=1.5' )
-
-optdepends=( 'python-scipy: for full SPM-ANALYZE support'
- 'python-pydicom>=0.9.7: for DICOM support'
- 'python-pillow: for PNG conversion in DICOMFS' )
-
-makedepends=('python-setuptools' 'python-nose' 'python-mock')
-source=("https://github.com/nipy/nibabel/archive/${pkgver}.tar.gz")
-md5sums=('f6e213894939aece4619e3a45259dfbd')
-
-
-build() {
- msg "Building ..."
- cd "$srcdir/nibabel-${pkgver}"
- python setup.py build
+arch=('x86_64') #i686 not tested
+url='http://nipy.org/nibabel/index.html'
+license=('MIT' 'BSD')
+depends=('python' 'python-numpy>=1.7.1' 'python-six>=1.3')
+# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
+makedepends=('python-setuptools') #('python-sphinx' 'python-numpydoc' 'python-matplotlib>=1.3')
+# checkdepends=('python-nose' 'python-mock')
+optdepends=('python-scipy: for full SPM-ANALYZE support' 'python-pydicom>=0.9.7: for DICOM support'
+ 'python-pillow: for PNG conversion in DICOMFS' 'python-indexed-gzip')
+install=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nipy/nibabel/archive/$pkgver.tar.gz")
+md5sums=('92a9d5d3d5de6bfb8754f8e4ba310e2d')
+
+build()
+{
+ cd "$srcdir/nibabel-$pkgver"
+ python setup.py build
}
-package_python-nibabel() {
-
- cd "$srcdir/nibabel-${pkgver}"
-
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
-
+package()
+{
+ cd "$srcdir/nibabel-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
}
+