summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:55 +0200
committerSébastien Leduc2015-06-13 10:51:55 +0200
commita3b5dab3e296f9f417e6f047145d9bc924a61262 (patch)
tree8cac31b2ea3684349ead836507e98404a13fef1b
downloadaur-a3b5dab3e296f9f417e6f047145d9bc924a61262.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a78180128156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-nmap
+ pkgdesc = A Python library which helps in using the nmap port scanner. required nmap software
+ pkgver = 0.3.7
+ pkgrel = 1
+ url = http://xael.org/norman/python/python-nmap
+ arch = any
+ license = GPL3
+ depends = python
+ depends = nmap
+ source = http://xael.org/norman/python/python-nmap/python-nmap-0.3.7.tar.gz
+ md5sums = 3ed35d4093a04b2ad2b3a6447dd0588e
+
+pkgname = python-nmap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c68805398eba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sebastien Leduc <sebastien AT sleduc DOT fr>
+# Contributor: sl13lp <slackpinguino@gmail.com>
+
+pkgname=python-nmap
+pkgver=0.3.7
+pkgrel=1
+pkgdesc="A Python library which helps in using the nmap port scanner. required nmap software"
+arch=("any")
+url="http://xael.org/norman/python/python-nmap"
+license=('GPL3')
+depends=('python' 'nmap')
+source="http://xael.org/norman/python/python-nmap/$pkgname-$pkgver.tar.gz"
+md5sums=('3ed35d4093a04b2ad2b3a6447dd0588e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}