summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2024-04-28 01:52:53 +0200
committerClaudia2024-04-28 01:57:07 +0200
commitb17c574cdff17aa4cb9a133aa2fc12d1150886c5 (patch)
tree6f0978eb1cecc7d6830e1e0cd0eb122af21bbddf
parentd085ae8473143874f45905e544dae7a73bbbaa96 (diff)
downloadaur-python-norbert.tar.gz
Add compatibility fix for Python 3.12 setuptools
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfe289c85e39..b5f1548c083e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-norbert
pkgdesc = Painless Wiener filters for audio separation
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sigsep/norbert
arch = any
license = MIT
@@ -10,6 +10,8 @@ pkgbase = python-norbert
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ depends = python
+ depends = python-numpy
depends = python-scipy
source = python-norbert-0.2.1.tar.gz::https://github.com/sigsep/norbert/archive/v0.2.1.tar.gz
sha512sums = d10abce6d06377def4b4fcec22ffe1a0bde74600b6d90f6a87d9f726284ba895c26af088ba78b537b82bc4797af5d5d924e8deeea3f88e3af119c1f9396058ea
diff --git a/PKGBUILD b/PKGBUILD
index ca471dab1821..bb87d5d2e9c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=python-norbert
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Painless Wiener filters for audio separation'
arch=('any')
url='https://github.com/sigsep/norbert'
license=('MIT')
-depends=('python-scipy')
+depends=('python' 'python-numpy' 'python-scipy')
checkdepends=('python-pytest')
makedepends=(
'python-build'
@@ -24,6 +24,13 @@ sha512sums=(
'd10abce6d06377def4b4fcec22ffe1a0bde74600b6d90f6a87d9f726284ba895c26af088ba78b537b82bc4797af5d5d924e8deeea3f88e3af119c1f9396058ea'
)
+prepare() {
+ cd "${srcdir}/${pkgname#python-}-${pkgver}"
+
+ # Compatibility fix for setuptools
+ sed -i -e 's/description-file/description_file/' setup.cfg
+}
+
build() {
cd "${srcdir}/${pkgname#python-}-${pkgver}"
python -m build --wheel --no-isolation