summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-04-20 11:10:20 +0200
committera8212024-04-20 11:10:20 +0200
commitcb0a82ce283557522f747fa61ae5e34f2f12cc71 (patch)
tree56aea5b69f92ee9d26a88c4e23f6c019727fdc63
parente84877bb516f2b8282eb5d72cbc4e11ecf7e610b (diff)
downloadaur-python-numpy-groupies.tar.gz
Version 0.11.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2a02a6ad9db..099e40a6b951 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-numpy-groupies
pkgdesc = Optimised tools for group-indexing operations for python numpy
- pkgver = 0.10.2
+ pkgver = 0.11.1
pkgrel = 1
url = https://github.com/ml31415/numpy-groupies
arch = any
- license = BSD
+ license = BSD-2-Clause
makedepends = git
makedepends = python-build
makedepends = python-installer
@@ -13,7 +13,7 @@ pkgbase = python-numpy-groupies
depends = python-numpy
optdepends = python-numba: for numba backend
optdepends = python-pandas: for pandas backend
- source = git+https://github.com/ml31415/numpy-groupies.git#commit=162fdb9bcf32c8748c264b513d15eb9390b498a6
- sha256sums = SKIP
+ source = git+https://github.com/ml31415/numpy-groupies.git#tag=v0.11.1
+ sha256sums = 9ac647bc9aeec60b81bde064f433383885546cecc9e9629a78bf151d1e38aaf6
pkgname = python-numpy-groupies
diff --git a/PKGBUILD b/PKGBUILD
index 3e8f4f25c9d7..bfbc28b750c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
pkgname=python-numpy-groupies
_name=numpy-groupies
-pkgver=0.10.2
+pkgver=0.11.1
pkgrel=1
pkgdesc='Optimised tools for group-indexing operations for python numpy'
arch=("any")
url="https://github.com/ml31415/numpy-groupies"
-license=('BSD')
+license=('BSD-2-Clause')
depends=('python-numpy')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
optdepends=(
'python-numba: for numba backend'
'python-pandas: for pandas backend'
)
-_commit=162fdb9bcf32c8748c264b513d15eb9390b498a6
-source=("git+${url}.git#commit=${_commit}")
-sha256sums=('SKIP')
+source=("git+${url}.git#tag=v${pkgver}")
+sha256sums=('9ac647bc9aeec60b81bde064f433383885546cecc9e9629a78bf151d1e38aaf6')
build() {
cd "${_name}"