summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Khodygo2019-05-29 22:49:14 +0100
committerVladimir Khodygo2019-05-29 22:49:14 +0100
commit10b21cb483b5c9a2d857fab87c75e49885597769 (patch)
tree7558fef896b06229dd82e6b9f00f0b41be0afbad
parentfb043384c62915c93c60cba5ae0f43210c5dc78f (diff)
downloadaur-10b21cb483b5c9a2d857fab87c75e49885597769.tar.gz
v1.16.4, remove redundant fix
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--fix_compiler.patch11
3 files changed, 9 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c08c013281d..82f1c3cb8060 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python compiled with intel mkl
- pkgver = 1.16.3
+ pkgver = 1.16.4
pkgrel = 1
url = http://numpy.scipy.org/
arch = i686
@@ -15,28 +15,26 @@ pkgbase = python-numpy-mkl
depends = python
depends = python2
options = staticlibs
- source = https://github.com/numpy/numpy/archive/v1.16.3.tar.gz
+ source = https://github.com/numpy/numpy/archive/v1.16.4.tar.gz
source = site64.cfg
source = site32.cfg
source = intelccompiler.py.patch
- source = fix_compiler.patch
- sha256sums = a4c331d8d5208f69ac909ea47b193608b3092c6ba39c00c2561e8d2e4e01c0a4
+ sha256sums = 3bdabda4a2ac4f1986b4bc55f865cd0b68b71edc9420b03e911e0ee52743e9c4
sha256sums = 86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1
sha256sums = 882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df
sha256sums = 0d185daf0f2fcab08778173f54cee86cd88dc3c6703413686ab3742c0097db4e
- sha256sums = 597b8f90f308d752862be08db9cf3cc90a1f2b8c9488ffe52d677648e1afc722
pkgname = python-numpy-mkl
depends = intel-mkl
depends = python
optdepends = python-pytest: testsuite
- provides = python-numpy=1.16.3
+ provides = python-numpy=1.16.4
conflicts = python-numpy
pkgname = python2-numpy-mkl
depends = intel-mkl
depends = python2
optdepends = python2-pytest: testsuite
- provides = python2-numpy=1.16.3
+ provides = python2-numpy=1.16.4
conflicts = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 114a0a7c9a6b..8c167dfe877a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgbase="python-numpy-mkl"
pkgname="python-numpy-mkl"
true && pkgname=('python-numpy-mkl' 'python2-numpy-mkl')
#pkgname=('python-numpy')
-pkgver=1.16.3
+pkgver=1.16.4
pkgrel=1
pkgdesc="Scientific tools for Python compiled with intel mkl"
arch=('i686' 'x86_64')
@@ -22,14 +22,12 @@ makedepends=('python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'int
source=(https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
'site64.cfg'
'site32.cfg'
- 'intelccompiler.py.patch'
- 'fix_compiler.patch')
+ 'intelccompiler.py.patch')
-sha256sums=('a4c331d8d5208f69ac909ea47b193608b3092c6ba39c00c2561e8d2e4e01c0a4'
+sha256sums=('3bdabda4a2ac4f1986b4bc55f865cd0b68b71edc9420b03e911e0ee52743e9c4'
'86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1'
'882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df'
- '0d185daf0f2fcab08778173f54cee86cd88dc3c6703413686ab3742c0097db4e'
- '597b8f90f308d752862be08db9cf3cc90a1f2b8c9488ffe52d677648e1afc722')
+ '0d185daf0f2fcab08778173f54cee86cd88dc3c6703413686ab3742c0097db4e')
build() {
#cd "${srcdir}"
@@ -122,7 +120,6 @@ package_python2-numpy-mkl() {
$(find ${pkgdir} -name '*.py')
mv "$pkgdir"/usr/bin/f2py{,2}
- patch ${pkgdir}/usr/lib/python2.7/site-packages/numpy/distutils/ccompiler.py < ${srcdir}/fix_compiler.patch
}
package_python-numpy-mkl() {
@@ -137,5 +134,4 @@ package_python-numpy-mkl() {
install -m755 -d "${pkgdir}/usr/share/licenses/python-numpy"
install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-numpy/"
- patch ${pkgdir}/usr/lib/python3.7/site-packages/numpy/distutils/ccompiler.py < ${srcdir}/fix_compiler.patch
}
diff --git a/fix_compiler.patch b/fix_compiler.patch
deleted file mode 100644
index 271ea016c55e..000000000000
--- a/fix_compiler.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ccompiler.py
-+++ ccompiler.py
-@@ -639,7 +639,7 @@
- return version
-
- try:
-- output = subprocess.check_output(version_cmd)
-+ output = subprocess.check_output(version_cmd, stderr=subprocess.STDOUT)
- except subprocess.CalledProcessError as exc:
- output = exc.output
- status = exc.returncode