summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2023-10-08 14:22:46 +0800
committerJingbei Li2023-10-08 14:22:46 +0800
commit25162263a0045b816156d9f200ecbeae9df59377 (patch)
tree45ea5ee4ef34d33bdae90ef5154d477499b7b18f
parent2e85a5939d5e85491c1e54d03286c4c6ae6d9f7f (diff)
downloadaur-25162263a0045b816156d9f200ecbeae9df59377.tar.gz
build with meson
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a162ee02f8..517aa026f40e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python, compiled with Intel MKL
pkgver = 1.26.0
- pkgrel = 1
- url = http://numpy.scipy.org/
+ pkgrel = 2
+ url = http://www.numpy.org/
arch = x86_64
- arch = i686
license = custom
checkdepends = python-pytest
checkdepends = python-hypothesis
makedepends = cython
- makedepends = gcc-fortran
+ makedepends = meson-python
makedepends = procps-ng
- makedepends = python-nose
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = intel-oneapi-mkl
- optdepends = python-nose: testsuite
provides = python-numpy=1.26.0
conflicts = python-numpy
- options = staticlibs
source = https://github.com/numpy/numpy/releases/download/v1.26.0/numpy-1.26.0.tar.gz
sha256sums = f93fc78fe8bf15afe2b8d6b6499f1c73953169fad1e9a8dd086cdff3190e7fdf
diff --git a/PKGBUILD b/PKGBUILD
index 958a1618fc7f..e12aa4045d8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,39 +8,39 @@
pkgname=python-numpy-mkl
pkgver=1.26.0
-pkgrel=1
+pkgrel=2
pkgdesc="Scientific tools for Python, compiled with Intel MKL"
-arch=('x86_64' 'i686')
+arch=('x86_64')
license=('custom')
-url="http://numpy.scipy.org/"
+url="http://www.numpy.org/"
provides=("python-numpy=$pkgver")
conflicts=('python-numpy')
depends=('python' 'intel-oneapi-mkl')
-optdepends=('python-nose: testsuite')
-makedepends=('cython' 'gcc-fortran' 'procps-ng' 'python-nose' 'python-setuptools')
+makedepends=('cython' 'meson-python' 'procps-ng' 'python-build' 'python-installer')
checkdepends=('python-pytest' 'python-hypothesis')
-options=('staticlibs')
source=("https://github.com/numpy/numpy/releases/download/v$pkgver/numpy-$pkgver.tar.gz")
sha256sums=('f93fc78fe8bf15afe2b8d6b6499f1c73953169fad1e9a8dd086cdff3190e7fdf')
build() {
source /opt/intel/oneapi/setvars.sh
cd numpy-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation \
+ -Csetup-args="-Dblas=mkl-dynamic-lp64-seq" \
+ -Csetup-args="-Dlapack=mkl-dynamic-lp64-seq"
}
check() {
- # TODO: Fix fortran tests here (it works fine after installation)
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+
cd numpy-$pkgver
- python setup.py install --root="$PWD/tmp_install" --optimize=1
+ python -m installer --destdir="$PWD/tmp_install" dist/*.whl
cd "$PWD/tmp_install"
- PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.11/site-packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
+ PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/$site_packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
}
package() {
cd numpy-$pkgver
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
- install -m755 -d "${pkgdir}/usr/share/licenses/python-numpy"
- install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-numpy/"
+ install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/python-numpy/"
}