summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Riva2018-03-15 20:52:37 +0100
committerSimone Riva2018-03-15 20:52:37 +0100
commit77c08f38f01dcff733dce162b50a6383f1793ebd (patch)
tree19aa3ae6f6c60e970855fcfd73b8c59629340494
parent059abb6c0329c2d2ea10f8b96d9f4e4f2b4f3fd4 (diff)
downloadaur-77c08f38f01dcff733dce162b50a6383f1793ebd.tar.gz
1.14.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD198
2 files changed, 103 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fa1feb70a9c..7fe5ee8799ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python compiled with intel mkl
- pkgver = 1.14.0
+ pkgver = 1.14.1
pkgrel = 1
url = http://numpy.scipy.org/
arch = i686
@@ -18,18 +18,18 @@ pkgbase = python-numpy-mkl
depends = python
depends = python2
options = staticlibs
- source = https://github.com/numpy/numpy/archive/v1.14.0.tar.gz
+ source = https://github.com/numpy/numpy/archive/v1.14.1.tar.gz
source = site64.cfg
source = site32.cfg
- sha256sums = 9dc112ff80ca7bc7c47ae7a6f23ae6211244005489b597d6ce05e9653f2a43d7
+ sha256sums = 3b10f4923c8073cd3fe2cf55b03e6e4723dc99cdb31e87beea666fef50fd32eb
sha256sums = 86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1
sha256sums = 882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df
pkgname = python-numpy-mkl
depends = intel-mkl
depends = python
- provides = python3-numpy=1.14.0
- provides = python-numpy=1.14.0
+ provides = python3-numpy=1.14.1
+ provides = python-numpy=1.14.1
conflicts = python3-numpy
conflicts = python-numpy
replaces = python3-numpy
@@ -38,7 +38,7 @@ pkgname = python2-numpy-mkl
depends = intel-mkl
depends = python2
optdepends = python-nose: testsuite
- provides = python2-numpy=1.14.0
+ provides = python2-numpy=1.14.1
conflicts = python2-numpy
replaces = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index b5c13fcb8b0d..996f2d4196d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,136 +1,132 @@
# $Id: PKGBUILD 164237 2012-07-28 03:14:33Z stephane $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
-# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Adapted to mkl by Simone Riva
pkgbase="python-numpy-mkl"
pkgname="python-numpy-mkl"
true && pkgname=('python-numpy-mkl' 'python2-numpy-mkl')
#pkgname=('python-numpy')
-pkgver=1.14.0
+pkgver=1.14.1
pkgrel=1
pkgdesc="Scientific tools for Python compiled with intel mkl"
arch=('i686' 'x86_64')
license=('custom')
options=('staticlibs')
url="http://numpy.scipy.org/"
-depends=( 'intel-mkl' 'python' 'python2' )
-makedepends=( 'python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'python-nose' 'python2-nose' 'cython' 'glibc' )
+depends=('intel-mkl' 'python' 'python2')
+makedepends=('python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'python-nose' 'python2-nose' 'cython' 'glibc')
-source=( https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
- 'site64.cfg'
- 'site32.cfg')
+source=(https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
+ 'site64.cfg' 'site32.cfg')
-sha256sums=( '9dc112ff80ca7bc7c47ae7a6f23ae6211244005489b597d6ce05e9653f2a43d7' # main pkg§
- '86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1' # site64
- '882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df' # site32
+sha256sums=('3b10f4923c8073cd3fe2cf55b03e6e4723dc99cdb31e87beea666fef50fd32eb' # main pkg§
+ '86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1' # site64
+ '882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df' # site32
)
build() {
- cd "${srcdir}"
-
- # set by hand this flag if you want to compile with gcc
- force_gcc=false
-
- if hash icc; then
- use_intel_cc=true
- use_gcc=false
- else
- use_intel_cc=false
- use_gcc=true
- fi
-
- if [ "$force_gcc" = true ] ; then
- use_intel_cc=false
- use_gcc=true
- fi
-
- if [ "$CARCH" = "i686" ]; then
- cp ${srcdir}/site32.cfg ${srcdir}/site.cfg
- _compiler=intel
- else
- cp ${srcdir}/site64.cfg ${srcdir}/site.cfg
- _compiler=intelem
- fi
-
-
-
- cp -a numpy-${pkgver} numpy-py2-${pkgver}
-
- export Atlas=None
- export LDFLAGS="$LDFLAGS -shared"
-
- if [ "$use_gcc" = true ]; then
- export CFLAGS="-fopenmp -m64 -mtune=native -O3 -Wl,--no-as-needed"
- export CXXFLAGS="-fopenmp -m64 -mtune=native -O3 -Wl,--no-as-needed"
- export LDFLAGS="-ldl -lm"
- export FFLAGS="-fopenmp -m64 -mtune=native -O3"
- fi
-
- # if [ "$use_intel_cc" = true ]; then
- # export __INTEL_PRE_CFLAGS="$__INTEL_PRE_CFLAGS -D_Float128=__float128"
- # fi
-
-
- echo "Building Python2"
- cd "${srcdir}"
- cp ${srcdir}/site.cfg "${srcdir}/numpy-py2-${pkgver}"
- cd "${srcdir}/numpy-py2-${pkgver}"
-
- if [ "$use_intel_cc" = true ]; then
- python2 setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
- fi
-
- if [ "$use_gcc" = true ]; then
- python2 setup.py config build_clib build_ext
- fi
-
- echo "Building Python3"
- cd "${srcdir}"
- cp ${srcdir}/site.cfg "${srcdir}/numpy-${pkgver}"
- cd "${srcdir}/numpy-${pkgver}"
-
- if [ "$use_intel_cc" = true ]; then
- python setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
- fi
-
- if [ "$use_gcc" = true ]; then
- python setup.py config build_clib build_ext
- fi
+ cd "${srcdir}"
+
+ # set by hand this flag if you want to compile with gcc
+ force_gcc=false
+
+ if hash icc; then
+ use_intel_cc=true
+ use_gcc=false
+ else
+ use_intel_cc=false
+ use_gcc=true
+ fi
+
+ if [ "$force_gcc" = true ]; then
+ use_intel_cc=false
+ use_gcc=true
+ fi
+
+ if [ "$CARCH" = "i686" ]; then
+ cp ${srcdir}/site32.cfg ${srcdir}/site.cfg
+ _compiler=intel
+ else
+ cp ${srcdir}/site64.cfg ${srcdir}/site.cfg
+ _compiler=intelem
+ fi
+
+ cp -a numpy-${pkgver} numpy-py2-${pkgver}
+
+ export Atlas=None
+ export LDFLAGS="$LDFLAGS -shared"
+
+ if [ "$use_gcc" = true ]; then
+ export CFLAGS="-fopenmp -m64 -mtune=native -O3 -Wl,--no-as-needed"
+ export CXXFLAGS="-fopenmp -m64 -mtune=native -O3 -Wl,--no-as-needed"
+ export LDFLAGS="-ldl -lm"
+ export FFLAGS="-fopenmp -m64 -mtune=native -O3"
+ fi
+
+ # if [ "$use_intel_cc" = true ]; then
+ # export __INTEL_PRE_CFLAGS="$__INTEL_PRE_CFLAGS -D_Float128=__float128"
+ # fi
+
+ echo "Building Python2"
+ cd "${srcdir}"
+ cp ${srcdir}/site.cfg "${srcdir}/numpy-py2-${pkgver}"
+ cd "${srcdir}/numpy-py2-${pkgver}"
+
+ if [ "$use_intel_cc" = true ]; then
+ python2 setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
+ fi
+
+ if [ "$use_gcc" = true ]; then
+ python2 setup.py config build_clib build_ext
+ fi
+
+ echo "Building Python3"
+ cd "${srcdir}"
+ cp ${srcdir}/site.cfg "${srcdir}/numpy-${pkgver}"
+ cd "${srcdir}/numpy-${pkgver}"
+
+ if [ "$use_intel_cc" = true ]; then
+ python setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
+ fi
+
+ if [ "$use_gcc" = true ]; then
+ python setup.py config build_clib build_ext
+ fi
}
package_python2-numpy-mkl() {
- depends=('intel-mkl' 'python2')
- provides=( "python2-numpy=${pkgver}" )
- replaces=( "python2-numpy" )
- conflicts=( "python2-numpy" )
- optdepends=('python-nose: testsuite')
+ depends=('intel-mkl' 'python2')
+ provides=("python2-numpy=${pkgver}")
+ replaces=("python2-numpy")
+ conflicts=("python2-numpy")
+ optdepends=('python-nose: testsuite')
- cd "${srcdir}/numpy-py2-${pkgver}"
- python2 setup.py config_fc install --prefix=/usr --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/numpy-py2-${pkgver}"
+ python2 setup.py config_fc install --prefix=/usr --root="${pkgdir}" --optimize=1
- install -m755 -d "${pkgdir}/usr/share/licenses/python2-numpy"
- install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-numpy/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/python2-numpy"
+ install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-numpy/"
- sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- $(find ${pkgdir} -name '*.py')
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+ $(find ${pkgdir} -name '*.py')
}
package_python-numpy-mkl() {
- depends=('intel-mkl' 'python')
- provides=("python3-numpy=${pkgver}" "python-numpy=${pkgver}")
- replaces=('python3-numpy')
- conflicts=('python3-numpy' 'python-numpy')
+ depends=('intel-mkl' 'python')
+ provides=("python3-numpy=${pkgver}" "python-numpy=${pkgver}")
+ replaces=('python3-numpy')
+ conflicts=('python3-numpy' 'python-numpy')
- cd "${srcdir}/numpy-${pkgver}"
- python setup.py config_fc install --prefix=/usr --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/numpy-${pkgver}"
+ python setup.py config_fc install --prefix=/usr --root="${pkgdir}" --optimize=1
- install -m755 -d "${pkgdir}/usr/share/licenses/python3-numpy"
- install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python3-numpy/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/python3-numpy"
+ install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python3-numpy/"
}