summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2020-12-01 02:21:49 +0900
committerXuanrui Qi2020-12-01 02:21:49 +0900
commitc8a1e72e5c1e50396f6d6e752a948349da36b176 (patch)
tree3181b58c2712642c538321d95bad18136850df07
parent60ad4d79cc8864d51352f00922683b88feee6a98 (diff)
downloadaur-c8a1e72e5c1e50396f6d6e752a948349da36b176.tar.gz
Version 1.19.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e999594a3c77..8330daafdc85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-mkl
- pkgdesc = Scientific tools for Python, compiled with intel mkl
- pkgver = 1.19.1
+ pkgdesc = Scientific tools for Python, compiled with Intel MKL
+ pkgver = 1.19.4
pkgrel = 1
url = http://numpy.scipy.org/
arch = x86_64
@@ -13,11 +13,11 @@ pkgbase = python-numpy-mkl
makedepends = cython>=0.29.21
depends = python>=3.6
depends = intel-mkl
- provides = python-numpy=1.19.1
+ provides = python-numpy=1.19.4
conflicts = python-numpy
options = staticlibs
- source = https://github.com/numpy/numpy/releases/download/v1.19.1/numpy-1.19.1.tar.gz
- sha256sums = 1396e6c3d20cbfc119195303b0272e749610b7042cc498be4134f013e9a3215c
+ source = https://github.com/numpy/numpy/releases/download/v1.19.4/numpy-1.19.4.tar.gz
+ sha256sums = fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413
pkgname = python-numpy-mkl
diff --git a/PKGBUILD b/PKGBUILD
index a3e75b6ebcdf..e69dd6aab5de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
# Adapted to mkl by Simone Riva
pkgname=python-numpy-mkl
-pkgver=1.19.1
+pkgver=1.19.4
pkgrel=1
-pkgdesc="Scientific tools for Python, compiled with intel mkl"
+pkgdesc="Scientific tools for Python, compiled with Intel MKL"
arch=('x86_64' 'i686')
license=('custom')
url="http://numpy.scipy.org/"
@@ -20,10 +20,12 @@ makedepends=('python-setuptools' 'gcc-fortran' 'cython>=0.29.21')
checkdepends=('python-pytest' 'python-hypothesis')
options=('staticlibs')
source=("https://github.com/numpy/numpy/releases/download/v$pkgver/numpy-$pkgver.tar.gz")
-sha256sums=('1396e6c3d20cbfc119195303b0272e749610b7042cc498be4134f013e9a3215c')
+sha256sums=('fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413')
prepare() {
export MKLROOT=/opt/intel/mkl
+ # https://github.com/numpy/numpy/issues/17390
+ sed -i '/error/a \ ignore:Module already imported so cannot be rewritten' numpy-$pkgver/pytest.ini
}
build() {