summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Khodygo2019-04-27 00:22:58 +0100
committerVladimir Khodygo2019-04-27 00:22:58 +0100
commitfb043384c62915c93c60cba5ae0f43210c5dc78f (patch)
tree5ce4c2cd2bc56c6a0e3f2f918372de7b0b40273e
parentcc00463b7c91987dfbfd42c71d994689d9e67deb (diff)
downloadaur-fb043384c62915c93c60cba5ae0f43210c5dc78f.tar.gz
v1.16.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--fix_compiler.patch4
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46fce9b95b1a..7c08c013281d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python compiled with intel mkl
- pkgver = 1.16.2
+ pkgver = 1.16.3
pkgrel = 1
url = http://numpy.scipy.org/
arch = i686
@@ -15,28 +15,28 @@ pkgbase = python-numpy-mkl
depends = python
depends = python2
options = staticlibs
- source = https://github.com/numpy/numpy/archive/v1.16.2.tar.gz
+ source = https://github.com/numpy/numpy/archive/v1.16.3.tar.gz
source = site64.cfg
source = site32.cfg
source = intelccompiler.py.patch
source = fix_compiler.patch
- sha256sums = 88835849921a970dae7705b0ea4a144d6b22f5e28148e17f25723c492a74a3c0
+ sha256sums = a4c331d8d5208f69ac909ea47b193608b3092c6ba39c00c2561e8d2e4e01c0a4
sha256sums = 86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1
sha256sums = 882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df
sha256sums = 0d185daf0f2fcab08778173f54cee86cd88dc3c6703413686ab3742c0097db4e
- sha256sums = 7389feba5dc3db997be652fc8d98d573a936c62c4ef5272c142598636fcea2df
+ sha256sums = 597b8f90f308d752862be08db9cf3cc90a1f2b8c9488ffe52d677648e1afc722
pkgname = python-numpy-mkl
depends = intel-mkl
depends = python
optdepends = python-pytest: testsuite
- provides = python-numpy=1.16.2
+ provides = python-numpy=1.16.3
conflicts = python-numpy
pkgname = python2-numpy-mkl
depends = intel-mkl
depends = python2
optdepends = python2-pytest: testsuite
- provides = python2-numpy=1.16.2
+ provides = python2-numpy=1.16.3
conflicts = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index c741239ff95e..114a0a7c9a6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgbase="python-numpy-mkl"
pkgname="python-numpy-mkl"
true && pkgname=('python-numpy-mkl' 'python2-numpy-mkl')
#pkgname=('python-numpy')
-pkgver=1.16.2
+pkgver=1.16.3
pkgrel=1
pkgdesc="Scientific tools for Python compiled with intel mkl"
arch=('i686' 'x86_64')
@@ -20,14 +20,16 @@ depends=('intel-mkl' 'python' 'python2')
makedepends=('python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'cython')
source=(https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
- 'site64.cfg' 'site32.cfg' 'intelccompiler.py.patch'
+ 'site64.cfg'
+ 'site32.cfg'
+ 'intelccompiler.py.patch'
'fix_compiler.patch')
-sha256sums=('88835849921a970dae7705b0ea4a144d6b22f5e28148e17f25723c492a74a3c0'
+sha256sums=('a4c331d8d5208f69ac909ea47b193608b3092c6ba39c00c2561e8d2e4e01c0a4'
'86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1'
'882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df'
'0d185daf0f2fcab08778173f54cee86cd88dc3c6703413686ab3742c0097db4e'
- '7389feba5dc3db997be652fc8d98d573a936c62c4ef5272c142598636fcea2df')
+ '597b8f90f308d752862be08db9cf3cc90a1f2b8c9488ffe52d677648e1afc722')
build() {
#cd "${srcdir}"
diff --git a/fix_compiler.patch b/fix_compiler.patch
index e0e8a1f0b221..271ea016c55e 100644
--- a/fix_compiler.patch
+++ b/fix_compiler.patch
@@ -1,5 +1,5 @@
---- ccompiler.py 2019-01-31 20:54:00.000000000 +0000
-+++ _ccompiler.py 2019-02-09 21:32:04.270976061 +0000
+--- ccompiler.py
++++ ccompiler.py
@@ -639,7 +639,7 @@
return version