summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2019-08-05 10:36:59 +0200
committerBlair Bonnett2019-08-05 10:36:59 +0200
commit2c478662f4fbe760e87296df84489238a963e33c (patch)
treea9b7118b08836cef1009c91098a43f21a10bbd24
downloadaur-2c478662f4fbe760e87296df84489238a963e33c.tar.gz
Initial package of 2019.7.23.15.26.49
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2005cd0e675
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-numpy-quaternion
+ pkgdesc = Add built-in support for quaternions to NumPy
+ pkgver = 2019.7.23.15.26.49
+ pkgrel = 1
+ url = https://github.com/moble/quaternion
+ arch = x86_64
+ license = MIT
+ depends = python-numpy>=1.3
+ source = https://files.pythonhosted.org/packages/source/n/numpy-quaternion/numpy-quaternion-2019.7.23.15.26.49.tar.gz
+ sha256sums = 42289bafc3292959173d93736f9c875b5c69d472934f04a76883b7b185adc42e
+
+pkgname = python-numpy-quaternion
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbf3fdd9285b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0afc3c24d679
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
+
+pkgname=python-numpy-quaternion
+pkgver=2019.7.23.15.26.49
+pkgrel=1
+pkgdesc="Add built-in support for quaternions to NumPy"
+url="https://github.com/moble/quaternion"
+arch=('x86_64')
+license=('MIT')
+depends=('python-numpy>=1.3')
+source=(
+ "https://files.pythonhosted.org/packages/source/n/numpy-quaternion/numpy-quaternion-$pkgver.tar.gz"
+)
+sha256sums=(
+ '42289bafc3292959173d93736f9c875b5c69d472934f04a76883b7b185adc42e'
+)
+
+build() {
+ cd "numpy-quaternion-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "numpy-quaternion-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}