summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2020-09-05 21:26:18 +0200
committerBlair Bonnett2020-09-05 21:26:18 +0200
commitf5b384c270c35ae99f26f75f23353a24e26a561e (patch)
tree51e97211676fa2c221ecd8c98dbf4e9b135acc69
parent8faf1ab4b05065b86d2d73cf3fb6556e59fc8eef (diff)
downloadaur-f5b384c270c35ae99f26f75f23353a24e26a561e.tar.gz
Update to 2020.9.5.14.42.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cd0ce627ef3..f1a5fc5c624b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-numpy-quaternion
pkgdesc = Add built-in support for quaternions to NumPy
- pkgver = 2020.5.19.15.27.24
+ pkgver = 2020.9.5.14.42.2
pkgrel = 1
url = https://quaternion.readthedocs.io/
arch = x86_64
license = MIT
checkdepends = python-pytest
+ checkdepends = python-pytest-cov
makedepends = python-setuptools
depends = python-numpy
depends = python-scipy
optdepends = python-numba: speedup of numerical functions
- source = https://files.pythonhosted.org/packages/source/n/numpy-quaternion/numpy-quaternion-2020.5.19.15.27.24.tar.gz
- sha256sums = 7102931862e13d2266b9255bef215becdedda1ad88d36390f974a58ad7d38b19
+ source = https://files.pythonhosted.org/packages/source/n/numpy-quaternion/numpy-quaternion-2020.9.5.14.42.2.tar.gz
+ sha256sums = 071c3edb814027f529c8cd78a8bd36aa7326d42bdf1d95d82db790cb356a9fc8
pkgname = python-numpy-quaternion
diff --git a/PKGBUILD b/PKGBUILD
index b1512ec23517..616eee0dd067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-numpy-quaternion
-pkgver=2020.5.19.15.27.24
+pkgver=2020.9.5.14.42.2
pkgrel=1
pkgdesc="Add built-in support for quaternions to NumPy"
url="https://quaternion.readthedocs.io/"
@@ -12,27 +12,27 @@ optdepends=(
"python-numba: speedup of numerical functions"
)
makedepends=('python-setuptools')
-checkdepends=('python-pytest')
+checkdepends=('python-pytest' 'python-pytest-cov')
source=(
"https://files.pythonhosted.org/packages/source/n/numpy-quaternion/numpy-quaternion-$pkgver.tar.gz"
)
sha256sums=(
- '7102931862e13d2266b9255bef215becdedda1ad88d36390f974a58ad7d38b19'
+ '071c3edb814027f529c8cd78a8bd36aa7326d42bdf1d95d82db790cb356a9fc8'
)
build() {
cd "numpy-quaternion-$pkgver"
- package_version="$pkgver" python setup.py build
+ python setup.py build
}
check() {
cd "numpy-quaternion-$pkgver"
PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-$PYVER" PYTHONDONTWRITEBYTECODE=1 pytest
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-$PYVER" PYTHONDONTWRITEBYTECODE=1 pytest --no-cov
}
package() {
cd "numpy-quaternion-$pkgver"
- package_version="$pkgver" python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}