summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatclab2023-11-25 12:08:52 +0100
committermatclab2023-11-25 12:08:52 +0100
commitb5424e02557eb600ca4a7ed8faacd682b72ad8b2 (patch)
treece7ba3b6229f1b4a10a56c5130e71a7a8381843e
downloadaur-python-ofxhome.tar.gz
First version, needed for ofxclient
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ed135b95718
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ofxhome
+ pkgdesc = ofxhome.com financial institution lookup REST client
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/captin411/ofxhome
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/o/ofxhome/ofxhome-0.3.3.tar.gz
+ sha256sums = 8510451fd228c30627c3d18c2e530df35944afc2a4c97c888df6262c3276fee6
+
+pkgname = python-ofxhome
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8381af204e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mathieu <mathieu@clabaut.net>
+pkgbase='python-ofxhome'
+pkgname=('python-ofxhome')
+_module='ofxhome'
+pkgver='0.3.3'
+pkgrel=1
+pkgdesc="ofxhome.com financial institution lookup REST client"
+url="https://github.com/captin411/ofxhome"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
+sha256sums=('8510451fd228c30627c3d18c2e530df35944afc2a4c97c888df6262c3276fee6')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}