summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-12-13 06:12:06 +0800
committerlilac2021-12-13 06:12:06 +0800
commit91d3d255bd27a4edbe9bf485ec160eb6692bda21 (patch)
treee243b6eee24fd3ea0594370f6d7f9922bb615f82
parente86d6f14925bf019f1216622a0ecf51aadc94ace (diff)
downloadaur-91d3d255bd27a4edbe9bf485ec160eb6692bda21.tar.gz
[lilac] updated to 1.10.0-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--build-fixes.patch48
-rw-r--r--notes.txt3
4 files changed, 33 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54884c7d0929..a2ccc610c3d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
- pkgver = 1.9.1
- pkgrel = 4
+ pkgver = 1.10.0
+ pkgrel = 2
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = gtest
- makedepends = gmock
makedepends = pybind11
makedepends = python-setuptools
makedepends = nlohmann-json
@@ -29,10 +27,9 @@ pkgbase = python-onnxruntime
depends = openmpi
depends = onednn
options = !lto
- source = git+https://github.com/microsoft/onnxruntime#tag=v1.9.1
+ source = git+https://github.com/microsoft/onnxruntime#tag=v1.10.0
source = git+https://github.com/onnx/onnx.git
source = git+https://github.com/dcleblanc/SafeInt.git
- source = git+https://github.com/martinmoene/optional-lite.git
source = git+https://github.com/tensorflow/tensorboard.git
source = git+https://github.com/dmlc/dlpack.git
source = git+https://github.com/jarro2783/cxxopts.git
@@ -47,8 +44,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = 685f0235abed6e1277dd0eb9bda56c464d1987fe7fc90a3550e17ec70cc49fd15f34996a0e159f9622c4ca3e6bf29917fe51b7849342531fa2a6808d782f1e06
+ sha512sums = 80ea85ea20bbbdec7991f965a66b627a5f42828bc0c72be0913078d927833a82402fb1af6c5c9f6ecae861b45582fa42c98ce83b02768e4bf875ab89dd1c607c
sha512sums = ad94af8bb25744b244c4f82e9a06189741f82b295a88523ca0e8005568fac710c2299d783989457e9cf96ef8da0593fb4f70c8792d416f44ab29d6493e204f13
sha512sums = 6735c7aca2ba2f1f2a5286eb064125bf7f2c68a575d572dd157769d15778ff3e717b3a53d696c767748229f23ee6c3a7c82679df1d86283d7c4dd0ec9103ae08
diff --git a/PKGBUILD b/PKGBUILD
index 95fc8eb131c0..5982f3230889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,19 @@ pkgbase=python-onnxruntime
# Not split DNNL EP to another package as it's needed unconditionally at runtime if built at compile time
# https://github.com/microsoft/onnxruntime/blob/v1.9.1/onnxruntime/python/onnxruntime_pybind_state.cc#L533
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=1.9.1
+pkgver=1.10.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=4
+pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
depends=(nsync re2 python-flatbuffers python-numpy python-onnx python-protobuf openmpi onednn)
-makedepends=(git cmake gtest gmock pybind11 python-setuptools nlohmann-json chrono-date boost eigen flatbuffers cuda cudnn nccl clang)
+makedepends=(git cmake pybind11 python-setuptools nlohmann-json chrono-date boost eigen flatbuffers cuda cudnn nccl clang)
# not de-vendored libraries
# onnx: needs shared libonnx (https://github.com/onnx/onnx/issues/3030)
source=("git+https://github.com/microsoft/onnxruntime#tag=v$pkgver"
"git+https://github.com/onnx/onnx.git"
"git+https://github.com/dcleblanc/SafeInt.git"
- "git+https://github.com/martinmoene/optional-lite.git"
"git+https://github.com/tensorflow/tensorboard.git"
"git+https://github.com/dmlc/dlpack.git"
"git+https://github.com/jarro2783/cxxopts.git"
@@ -32,8 +31,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '685f0235abed6e1277dd0eb9bda56c464d1987fe7fc90a3550e17ec70cc49fd15f34996a0e159f9622c4ca3e6bf29917fe51b7849342531fa2a6808d782f1e06'
+ '80ea85ea20bbbdec7991f965a66b627a5f42828bc0c72be0913078d927833a82402fb1af6c5c9f6ecae861b45582fa42c98ce83b02768e4bf875ab89dd1c607c'
'ad94af8bb25744b244c4f82e9a06189741f82b295a88523ca0e8005568fac710c2299d783989457e9cf96ef8da0593fb4f70c8792d416f44ab29d6493e204f13'
'6735c7aca2ba2f1f2a5286eb064125bf7f2c68a575d572dd157769d15778ff3e717b3a53d696c767748229f23ee6c3a7c82679df1d86283d7c4dd0ec9103ae08')
# CUDA seems not working with LTO
@@ -48,9 +46,11 @@ prepare() {
patch -Np1 -i ../build-fixes.patch
patch -Np1 -i ../clang.patch
patch -Np1 -i ../system-dnnl.diff
+ # Fix building DNNL EP with clang https://github.com/microsoft/onnxruntime/pull/10014
+ git cherry-pick -n c2d08a877b1f661eb99a29a57fd4184aa0918a80
git submodule init
- for mod in onnx SafeInt optional-lite tensorboard dlpack cxxopts pytorch_cpuinfo; do
+ for mod in onnx SafeInt tensorboard dlpack cxxopts pytorch_cpuinfo; do
git config submodule.cmake/external/$mod.url "$srcdir"/$mod
git submodule update cmake/external/$mod
done
@@ -64,6 +64,7 @@ build() {
-Donnxruntime_ENABLE_PYTHON=ON
-Donnxruntime_PREFER_SYSTEM_LIB=ON
-Donnxruntime_BUILD_SHARED_LIB=ON
+ -Donnxruntime_BUILD_UNIT_TESTS=OFF
-Donnxruntime_ENABLE_TRAINING=ON
-Donnxruntime_USE_MPI=ON
-Donnxruntime_USE_PREINSTALLED_EIGEN=ON
diff --git a/build-fixes.patch b/build-fixes.patch
index 129aa988523e..25b410c9c005 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -2,44 +2,38 @@ diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index a027c69e0..eb7608518 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
-@@ -753,7 +753,8 @@ get_filename_component(ORTTRAINING_ROOT "${ORTTRAINING_ROOT}" ABSOLUTE)
- get_filename_component(REPO_ROOT "${REPO_ROOT}" ABSOLUTE)
- set(ONNXRUNTIME_INCLUDE_DIR ${REPO_ROOT}/include/onnxruntime)
+@@ -841,7 +841,9 @@ add_library(safeint_interface INTERFACE)
+ target_include_directories(safeint_interface INTERFACE ${SAFEINT_INCLUDE_DIR})
--add_subdirectory(external/date EXCLUDE_FROM_ALL)
-+find_package(date REQUIRED)
-+add_library(date_interface ALIAS date::date)
-
- set(SAFEINT_INCLUDE_DIR ${REPO_ROOT}/cmake/external/SafeInt)
- add_library(safeint_interface INTERFACE)
-@@ -764,14 +765,17 @@ if(onnxruntime_DISABLE_EXCEPTIONS)
- add_compile_definitions(optional_CONFIG_NO_EXCEPTIONS=1)
+ if (onnxruntime_PREFER_SYSTEM_LIB)
+- find_package(boost_mp11)
++ # boost on Arch does not support find_package(boost_mp11)
++ add_library(boost_mp11 INTERFACE)
++ add_library(Boost::mp11 ALIAS boost_mp11)
endif()
-
--add_subdirectory(external/mp11 EXCLUDE_FROM_ALL)
-+add_library(boost_mp11 INTERFACE)
-+add_library(Boost::mp11 ALIAS boost_mp11)
+ if (NOT TARGET Boost::mp11)
+ add_subdirectory(external/mp11 EXCLUDE_FROM_ALL)
+@@ -764,10 +765,12 @@ if(onnxruntime_DISABLE_EXCEPTIONS)
set(JSON_BuildTests OFF CACHE INTERNAL "")
set(JSON_Install OFF CACHE INTERNAL "")
-add_subdirectory(external/json EXCLUDE_FROM_ALL)
+find_package(nlohmann_json REQUIRED)
- if(onnxruntime_PREFER_SYSTEM_LIB)
+ if (onnxruntime_PREFER_SYSTEM_LIB)
- find_package(re2)
+ find_package(PkgConfig)
+ pkg_check_modules(RE2 IMPORTED_TARGET re2)
+ add_library(re2::re2 ALIAS PkgConfig::RE2)
endif()
- if(NOT TARGET re2::re2)
+ if (NOT TARGET re2::re2)
add_subdirectory(external/re2 EXCLUDE_FROM_ALL)
-@@ -1261,7 +1265,8 @@ set(FLATBUFFERS_INSTALL OFF CACHE BOOL "FLATBUFFERS_INSTALL" FORCE)
- set(FLATBUFFERS_BUILD_FLATHASH OFF CACHE BOOL "FLATBUFFERS_BUILD_FLATHASH" FORCE)
- set(FLATBUFFERS_BUILD_FLATLIB ON CACHE BOOL "FLATBUFFERS_BUILD_FLATLIB" FORCE)
- set_msvc_c_cpp_compiler_warning_level(4)
--add_subdirectory(external/flatbuffers EXCLUDE_FROM_ALL)
-+find_package(Flatbuffers REQUIRED)
-+add_library(flatbuffers ALIAS flatbuffers::flatbuffers_shared)
- set_msvc_c_cpp_compiler_warning_level(3)
- list(APPEND onnxruntime_EXTERNAL_DEPENDENCIES flatbuffers)
- list(APPEND onnxruntime_EXTERNAL_LIBRARIES flatbuffers)
+@@ -1421,7 +1421,7 @@
+ find_package(Flatbuffers)
+ endif()
+ if (Flatbuffers_FOUND)
+- add_library(flatbuffers ALIAS flatbuffers::flatbuffers)
++ add_library(flatbuffers ALIAS flatbuffers::flatbuffers_shared)
+ else()
+ add_subdirectory(external/flatbuffers EXCLUDE_FROM_ALL)
+ endif()
diff --git a/notes.txt b/notes.txt
deleted file mode 100644
index 62efe9cd463b..000000000000
--- a/notes.txt
+++ /dev/null
@@ -1,3 +0,0 @@
-Build system changes in 1.10
- Build: respect onnxruntime_PREFER_SYSTEM_LIB for more things https://github.com/microsoft/onnxruntime/pull/9181
- Remove optional-lite https://github.com/microsoft/onnxruntime/pull/9424