summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2025-01-08 18:23:48 -0300
committerDaniel Bermond2025-01-08 18:23:48 -0300
commit680280c1b198a49025ee3736dce42152d11b66c3 (patch)
tree33c41834d126a89e8f8d6e54a1a0548145929335
downloadaur-python-openvino-telemetry-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3be9f0dd5bca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-openvino-telemetry-git
+ pkgdesc = Pythno library for sending statistics data from the OpenVINO toolkit components (git version)
+ pkgver = r58.g4a7e3b6
+ pkgrel = 1
+ url = https://github.com/openvinotoolkit/telemetry/
+ arch = any
+ license = Apache-2.0
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ provides = openvino-telemetry
+ conflicts = openvino-telemetry
+ source = openvino-telemetry::git+https://github.com/openvinotoolkit/telemetry.git
+ sha256sums = SKIP
+
+pkgname = python-openvino-telemetry-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2f84987b461
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
+
+pkgname=python-openvino-telemetry-git
+pkgver=r58.g4a7e3b6
+pkgrel=1
+pkgdesc='Pythno library for sending statistics data from the OpenVINO toolkit components (git version)'
+arch=('any')
+url='https://github.com/openvinotoolkit/telemetry/'
+license=('Apache-2.0')
+depends=('python')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+provides=('openvino-telemetry')
+conflicts=('openvino-telemetry')
+source=('openvino-telemetry'::'git+https://github.com/openvinotoolkit/telemetry.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd openvino-telemetry
+ ( set -o pipefail
+ git describe --long --abbrev='7' 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short='7' HEAD)"
+ )
+}
+
+build() {
+ cd openvino-telemetry
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ python -m installer --destdir="$pkgdir" openvino-telemetry/dist/*.whl
+}