summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-12 16:15:36 +0200
committerChristopher Arndt2018-08-12 16:15:36 +0200
commit4409b2bc5da877b8538ed212a1259182f0239521 (patch)
tree9e3d2b0bfd4b2deb6592a29cf8817f3a869466f5
parent4650b333ac6b44f5bf1ac0f19edc517d4b5cfeac (diff)
downloadaur-python-p4a-build.tar.gz
Newer upstream version; update (make)depends; patch sources to use setuptools instead of distutils
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9672725f3e56..5b5af69f3cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-p4a-build
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = http://android.kivy.org/
arch = any
license = LGPL3
- source = https://pypi.python.org/packages/source/p/p4a-build/p4a-build-1.0.1.tar.gz
- md5sums = dcc80488b70bf27544e3ccafca95ef61
+ makedepends = python-setuptools
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/p/p4a-build/p4a-build-1.0.2.tar.gz
+ md5sums = 29a617986107c7d3d5d26ea4790ea6ad
pkgname = python-p4a-build
pkgdesc = Build tool for the P4A (Python for Android) build cloud
@@ -14,7 +16,7 @@ pkgname = python-p4a-build
pkgname = python2-p4a-build
pkgdesc = Build tool for the P4A (Python for Android) build cloud
- depends =
+ depends = python-requests
depends = python2
depends = python2-requests
diff --git a/PKGBUILD b/PKGBUILD
index 5f5be88a6ea7..e163fb9f49ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,25 @@
_pkgname=p4a-build
pkgname=(python-$_pkgname python2-$_pkgname)
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
url="http://android.kivy.org/"
license=('LGPL3')
arch=('any')
-source=("https://pypi.python.org/packages/source/p/p4a-build/p4a-build-$pkgver.tar.gz")
-md5sums=('dcc80488b70bf27544e3ccafca95ef61')
+depends=('python-requests')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-$pkgver.tar.gz")
+md5sums=('29a617986107c7d3d5d26ea4790ea6ad')
prepare() {
cp -r $_pkgname-${pkgver} python2-$_pkgname-${pkgver}
+
+ cd $srcdir/$_pkgname-${pkgver}
+ sed -i -e 's/distutils\.core/setuptools/' setup.py
+
+ cd $srcdir/python2-$_pkgname-${pkgver}
+ sed -i -e 's/distutils\.core/setuptools/' setup.py
}
build() {