summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomislav Ivek2019-12-11 11:49:59 +0100
committerTomislav Ivek2019-12-11 11:49:59 +0100
commit722684f2a160ab7f3bd18c56db0716a72dc346a0 (patch)
tree04b3385ae6e5ae14b188c567f727e5bf6c8c895e
parentade80f3072b61d0edd1f6ed56b32d4701aad8b70 (diff)
downloadaur-722684f2a160ab7f3bd18c56db0716a72dc346a0.tar.gz
patch-ng 1.17.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b9558d64353..747af66a8d8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-patch-ng
pkgdesc = Library to parse and apply unified diffs forked from python-patch.
- pkgver = 1.17.1
- pkgrel = 2
+ pkgver = 1.17.2
+ pkgrel = 1
url = https://github.com/conan-io/python-patch/
arch = any
license = MIT
makedepends = python-setuptools
makedepends = fakeroot
depends = python
- source = https://github.com/conan-io/python-patch-ng/archive/1.17.1.tar.gz
- source = https://raw.githubusercontent.com/conan-io/python-patch-ng/1.17.1/LICENSE
- md5sums = 7e5612deaa2cec54e9a924b09cbd2c6a
- md5sums = 505d9f4b8b27052bef960af06bfdfe01
+ source = python-patch-ng-1.17.2.tar.gz::https://files.pythonhosted.org/packages/source/p/patch-ng/patch-ng-1.17.2.tar.gz
+ md5sums = 412d77250d0d70a76a90eba3e28f3840
pkgname = python-patch-ng
diff --git a/PKGBUILD b/PKGBUILD
index 4b6c62e34372..da87ee5cfeaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Tomislav Ivek <tomislav dot ivek at gmail dot com>
pkgname=python-patch-ng
-pkgver=1.17.1
-pkgrel=2
+pkgver=1.17.2
+pkgrel=1
pkgdesc='Library to parse and apply unified diffs forked from python-patch.'
arch=('any')
url="https://github.com/conan-io/python-patch/"
license=('MIT')
depends=('python')
makedepends=('python-setuptools' 'fakeroot')
-source=("https://github.com/conan-io/python-patch-ng/archive/${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/conan-io/python-patch-ng/${pkgver}/LICENSE")
-md5sums=('7e5612deaa2cec54e9a924b09cbd2c6a'
- '505d9f4b8b27052bef960af06bfdfe01')
+_name=${pkgname#python-}
+source=($pkgname-$pkgver.tar.gz::"https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+# "https://raw.githubusercontent.com/conan-io/python-patch-ng/${pkgver}/LICENSE")
+md5sums=('412d77250d0d70a76a90eba3e28f3840')
build() {
- cd "$srcdir/python-patch-ng-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/python-patch-ng-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py install --optimize=1 --root "$pkgdir"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}