summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLetu Ren2022-03-17 22:44:44 +0800
committerLetu Ren2022-03-17 22:44:44 +0800
commit24ace7b910a77fb7f1c358b78eb1377cc24b233a (patch)
tree076cdc55d91ce23e6b12bc02cb292ebbf05b123d
parentb516df4c07989f7ece7d01d3f4c120c895c4b754 (diff)
downloadaur-python-pdfkit.tar.gz
upgrade to 1.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e97f1e93f16..45ae8de4f924 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pdfkit
- pkgdesc = Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt
- pkgver = 0.6.1
+ pkgdesc = Wkhtmltopdf python wrapper to convert html to pdf
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/JazzCore/python-pdfkit
arch = any
@@ -8,10 +8,7 @@ pkgbase = python-pdfkit
makedepends = python-setuptools
depends = python
depends = wkhtmltopdf
- source = https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-0.6.1.tar.gz
- sha256sums = ef1da35b78d534197e7ce4a604a4a190e9aa769e56634957535f3479a50d8cd1
+ source = https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-1.0.0.tar.gz
+ sha256sums = 992f821e1e18fc8a0e701ecae24b51a2d598296a180caee0a24c0af181da02a9
pkgname = python-pdfkit
- depends = python
- depends = wkhtmltopdf
-
diff --git a/PKGBUILD b/PKGBUILD
index 9c3a1d7f7583..92f4d62a1fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
+# Maintainer: Letu Ren <fantasquex at gmail dot com>
+# Contributor: Sumner Evans <sumner.evans98 at gmail dot com>
pkgbase='python-pdfkit'
pkgname=('python-pdfkit')
-_module='pdfkit'
-pkgver='0.6.1'
+pkgver='1.0.0'
pkgrel=1
-pkgdesc='Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt'
+pkgdesc='Wkhtmltopdf python wrapper to convert html to pdf '
+arch=('any')
url='https://github.com/JazzCore/python-pdfkit'
+license=('MIT')
depends=(
'python'
'wkhtmltopdf'
)
makedepends=('python-setuptools')
-license=('MIT')
-arch=('any')
-source=('https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-0.6.1.tar.gz')
-sha256sums=('ef1da35b78d534197e7ce4a604a4a190e9aa769e56634957535f3479a50d8cd1')
-
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('992f821e1e18fc8a0e701ecae24b51a2d598296a180caee0a24c0af181da02a9')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_name}-${pkgver}"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+