summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-11-06 18:28:28 +0100
committerChristian Rebischke2016-11-06 18:28:28 +0100
commitdec55af4061b3c28ccd96972eee7c6129138d339 (patch)
treef6e75dfd0e379bb5f517c018dd982b89df57ffc5
parent357bd2fc4f197edd2c21739ea279693ed38cf6ea (diff)
downloadaur-python-pdns.tar.gz
pkgbuild adjustments
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6643fc56802..878e10c656f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Sun Nov 6 17:28:20 UTC 2016
pkgbase = python-pdns
pkgdesc = Command line client to synchronize PowerDNS hosted zones with local zone files
pkgver = 0.1.4
@@ -7,6 +9,8 @@ pkgbase = python-pdns
license = BSD
makedepends = python
makedepends = python2
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
source = https://pypi.python.org/packages/source/p/pdns/pdns-0.1.4.tar.gz
sha512sums = 86f11cae4e6264109d0a1ce0fd11f26f557475563ee677648f15098f1430845f495b38a0a0383aa15b6f1ad1920b366ddac05a9879ef3e6c1a14cc74ef4289e0
diff --git a/PKGBUILD b/PKGBUILD
index 25735b58b479..8a4f6d8f098f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-pdns
_pyname=pdns
pkgname=('python-pdns' 'python2-pdns')
-makedepends=('python' 'python2')
+makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
pkgver=0.1.4
pkgrel=1
pkgdesc="Command line client to synchronize PowerDNS hosted zones with local zone files"
@@ -14,16 +14,16 @@ sha512sums=('86f11cae4e6264109d0a1ce0fd11f26f557475563ee677648f15098f1430845f495
package_python-pdns() {
depends=('python')
- cd "$srcdir/$_pyname-$pkgver"
- python setup.py install -O1 --root=$pkgdir
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py install -O1 --root=${pkgdir}
install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
}
package_python2-pdns() {
depends=('python2')
- cd "$srcdir/$_pyname-$pkgver"
- python2 setup.py install -O1 --root=$pkgdir
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python2 setup.py install -O1 --root=${pkgdir}
install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
}