summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd2024-04-06 00:22:04 +0200
committerfossdd2024-04-06 00:22:04 +0200
commit6611c85f28c704ebd8cefd5fd069d057aeb88b39 (patch)
treed0fd349ae7ce9fb047f8f4188816abb2ceb5a4fe
downloadaur-python-pipx-git.tar.gz
upgpkg: python-pipx-git r723.9ae41342-1
upstream release
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e59b850244b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-pipx-git
+ pkgdesc = Install and Run Python Applications in Isolated Environments
+ pkgver = r723.9ae41342
+ pkgrel = 1
+ url = https://github.com/pipxproject/pipx
+ arch = any
+ license = MIT
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatchling
+ makedepends = python-wheel
+ makedepends = python-hatch-vcs
+ depends = python
+ depends = python-userpath
+ depends = python-argcomplete
+ depends = python-packaging
+ depends = python-platformdirs
+ provides = python-pipx
+ conflicts = python-pipx
+ source = git+https://github.com/pipxproject/pipx.git
+ sha512sums = SKIP
+
+pkgname = python-pipx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06cd7184de02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
+# Maintainer: fossdd <fossdd@pwned.life>
+
+__pkgname=pipx
+_pkgname=python-$__pkgname
+pkgname=$_pkgname-git
+pkgver=r723.9ae41342
+pkgrel=1
+pkgdesc='Install and Run Python Applications in Isolated Environments'
+arch=('any')
+url='https://github.com/pipxproject/pipx'
+license=('MIT' 'BSD')
+conflicts=($_pkgname)
+provides=($_pkgname)
+depends=('python' 'python-userpath' 'python-argcomplete' 'python-packaging' 'python-platformdirs')
+makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-wheel' 'python-hatch-vcs')
+#checkdepends=('python-tox' 'python-pytest')
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$__pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$__pkgname
+
+ #SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver} \
+ python -m build -nw
+}
+
+#check() {
+# cd $srcdir/$__pkgname
+#
+# nox
+#}
+
+package() {
+ cd $srcdir/$__pkgname
+
+ python -m installer -d "$pkgdir" dist/*.whl
+
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: