summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu, Zhenyu2024-04-09 15:13:06 +0800
committerWu, Zhenyu2024-04-09 15:13:06 +0800
commit41bbee9db1faa0d85e7d814b243e2e5aa93a473e (patch)
treefc50dada82fc667f80d53437c170ada2ff09339c
parent502fdb2fd3ebb1d44ea6796933656057cdf8c559 (diff)
downloadaur-python-plants-vs-zombies.tar.gz
:arrow_up: Upgrade
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6621dae9d5f..1c93b1e272fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-plants-vs-zombies
- pkgver = 0.0.1
+ pkgdesc = a simple PlantsVsZombies game
+ pkgver = 0.0.5
pkgrel = 1
url = https://github.com/marblexu/PythonPlantsVsZombies
arch = any
license = MIT
makedepends = python-installer
depends = python-pygame
- source = https://files.pythonhosted.org/packages/py3/p/plants_vs_zombies/plants_vs_zombies-0.0.1-py3-none-any.whl
- sha256sums = 8bfae4d34c040c8640ef773bca172d28c6b9605f4da4561fd2afe91c37244fc5
+ source = https://files.pythonhosted.org/packages/py3/p/plants_vs_zombies/plants_vs_zombies-0.0.5-py3-none-any.whl
+ sha256sums = c74a46fe7bda5c8f3f379e69c9584140af79d524a30b9ed255659ba9ce11eabb
pkgname = python-plants-vs-zombies
diff --git a/PKGBUILD b/PKGBUILD
index 6fe27124ae5c..f822c8cfe4e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# shellcheck shell=bash disable=SC2034,SC2154
_pkgname=plants-vs-zombies
pkgname=python-$_pkgname
-pkgver=0.0.1
+pkgver=0.0.5
pkgrel=1
-pkgdesc=""
+pkgdesc="a simple PlantsVsZombies game"
arch=(any)
url=https://github.com/marblexu/PythonPlantsVsZombies
depends=(python-pygame)
@@ -11,7 +11,7 @@ makedepends=(python-installer)
license=(MIT)
_py=py3
source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/${_pkgname//-/_}/${_pkgname//-/_}-$pkgver-$_py-none-any.whl")
-sha256sums=('8bfae4d34c040c8640ef773bca172d28c6b9605f4da4561fd2afe91c37244fc5')
+sha256sums=('c74a46fe7bda5c8f3f379e69c9584140af79d524a30b9ed255659ba9ce11eabb')
package() {
python -minstaller -d"$pkgdir" ./*.whl