summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Mailänder2025-02-16 13:39:17 +0100
committerMatthias Mailänder2025-02-16 13:39:17 +0100
commit0ffb58a88cdcc4571f31c415046f93c80090d747 (patch)
tree76585527bbc6bd137ea1c8efb9c5001062558bf2
parentd83164e730debe9a81ff1be54f36e4c32bc01aeb (diff)
downloadaur-python-plotdigitizer.tar.gz
Update to version 0.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 825ea3bc2bb2..71656be01b96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-plotdigitizer
pkgdesc = A Python utility to digitize plots.
- pkgver = 0.2.3
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/dilawar/PlotDigitizer
arch = any
@@ -9,6 +9,8 @@ pkgbase = python-plotdigitizer
makedepends = python-installer
makedepends = python-poetry-core
makedepends = python-wheel
+ makedepends = python-typer
+ makedepends = python-loguru
depends = python-cycler
depends = python-contourpy
depends = python-fonttools
@@ -18,7 +20,7 @@ pkgbase = python-plotdigitizer
depends = python-pillow
depends = python-pyparsing
depends = python-dateutil
- source = plotdigitizer-0.2.3.tar.gz::https://github.com/dilawar/PlotDigitizer/archive/refs/tags/v0.2.3.tar.gz
- sha256sums = ad8af36f452a9431311004a32535f80b1316670dbf13f9bd31fed7f63e152444
+ source = plotdigitizer-0.3.1.tar.gz::https://github.com/dilawar/PlotDigitizer/archive/refs/tags/v0.3.1.tar.gz
+ sha256sums = b2a6039e2f09251683a2ba82f271014f3359e65736341bc65d884e9c9a67be75
pkgname = python-plotdigitizer
diff --git a/PKGBUILD b/PKGBUILD
index 00eaae5f541e..36b225ea093c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Matthias Mailänder <matthias@mailaender.name>
pkgname=python-plotdigitizer
-pkgver=0.2.3
+pkgver=0.3.1
pkgrel=1
pkgdesc=" A Python utility to digitize plots."
arch=('any')
url="https://github.com/dilawar/PlotDigitizer"
license=('GPL-3.0')
depends=('python-cycler' 'python-contourpy' 'python-fonttools' 'python-kiwisolver' 'python-numpy' 'python-packaging' 'python-pillow' 'python-pyparsing' 'python-dateutil')
-makedepends=('python-build' 'python-installer' 'python-poetry-core' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-poetry-core' 'python-wheel' 'python-typer' 'python-loguru')
source=("plotdigitizer-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('ad8af36f452a9431311004a32535f80b1316670dbf13f9bd31fed7f63e152444')
+sha256sums=('b2a6039e2f09251683a2ba82f271014f3359e65736341bc65d884e9c9a67be75')
build() {
cd "PlotDigitizer-$pkgver"