summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-02-09 13:15:58 +0100
committerAlphaJack2024-02-09 13:15:58 +0100
commit5d5e194989d39bce03714f3197a179e72f93ee31 (patch)
treea6a09d258dc816e72b1ff7abd4cfa88611a797bc
parent7af5e23b434df903c594ed4da4157eab687b1a1c (diff)
downloadaur-python-polyline.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 574ef82915cf..c969c1cf2a2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-polyline
- pkgdesc = Python implementation of Google's Encoded Polyline Algorithm Format.
- pkgver = 1.4.0
+ pkgdesc = A Python implementation of Google's Encoded Polyline Algorithm Format
+ pkgver = 2.0.1
pkgrel = 1
- url = https://github.com/hicsail/polyline
+ url = https://github.com/frederickjansen/polyline
arch = any
license = MIT
- makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = python
- source = git+https://github.com/hicsail/polyline#tag=v1.4.0
- sha256sums = SKIP
+ makedepends = python-wheel
+ options = !strip
+ source = https://pypi.org/packages/source/p/polyline/polyline-2.0.1.tar.gz
+ b2sums = b83167496a23fce2a8c3318ecec3d7a319e136c14e70d63761fabc88927b7825bda80210b16f0555e726a2541a21235a638cb91670dc68201a2f2e682ad7023b
pkgname = python-polyline
-
diff --git a/PKGBUILD b/PKGBUILD
index 777abc683881..f2bbe66bdfe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: tembleking <tembleking at gmail dot com>
-# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
+# Maintainer: AlphaJack <alphajack at tuta dot io>
-pkgname=python-polyline
-pkgver=1.4.0
+pkgname="python-polyline"
+_name="${pkgname#python-}"
+pkgver=2.0.1
pkgrel=1
-pkgdesc="Python implementation of Google's Encoded Polyline Algorithm Format."
-arch=("any")
-url="https://github.com/hicsail/polyline"
+pkgdesc="A Python implementation of Google's Encoded Polyline Algorithm Format"
+arch=(any)
+url="https://github.com/frederickjansen/polyline"
license=('MIT')
-makedepends=("git" "python-setuptools")
-depends=("python")
-source=("git+https://github.com/hicsail/polyline#tag=v${pkgver}")
-sha256sums=('SKIP')
+depends=()
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+b2sums=('b83167496a23fce2a8c3318ecec3d7a319e136c14e70d63761fabc88927b7825bda80210b16f0555e726a2541a21235a638cb91670dc68201a2f2e682ad7023b')
+options=("!strip")
-build() {
- cd "$srcdir/polyline"
- python setup.py build
+build(){
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
-package() {
- cd "$srcdir/polyline"
- python setup.py install --root="$pkgdir" --optimize=1
-
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+package(){
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}