summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2015-07-20 21:53:34 +0200
committerTimothée Ravier2015-07-20 21:53:34 +0200
commitce923d4bfc59fb712f1c8788d3bdf83d26ecc824 (patch)
treeccbf0ce4a30574049809cf2b9b4b3e07e9d9b804
parent79280c5f4656ec2ab7c148f2b05e22a0c3b21abe (diff)
downloadaur-ce923d4bfc59fb712f1c8788d3bdf83d26ecc824.tar.gz
Fix selective split build
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09f8f6c1b394..3a4eb1048b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,8 +25,12 @@ pkgver() {
build() {
cd "${_gitname}"/docs
- make man SPHINXBUILD=sphinx-build2 BUILDDIR=_build-python2
- make man SPHINXBUILD=sphinx-build BUILDDIR=_build-python
+ if [ -x "/usr/bin/sphinx-build2" ]; then
+ make man SPHINXBUILD=sphinx-build2 BUILDDIR=_build-python2
+ fi
+ if [ -x "/usr/bin/sphinx-build" ]; then
+ make man SPHINXBUILD=sphinx-build BUILDDIR=_build-python
+ fi
}
package_generic() {