summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-27 20:56:44 -0500
committerCarlos Aznarán2024-01-27 20:56:44 -0500
commit9bf2bd96eb7e44c03f9fbd845867e8f4d874eb46 (patch)
treeffe2402888f378458f3b4c957e47dc7a93887ca1
parent8cbc998538fc027963c266a964a3018c2429e90f (diff)
downloadaur-python-ppft.tar.gz
Bump version to 1.7.6.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1ba2f308fe0..541eca3e5165 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ppft
pkgdesc = distributed and parallel python
- pkgver = 1.7.6.7
+ pkgver = 1.7.6.8
pkgrel = 1
url = https://github.com/uqfoundation/ppft
arch = any
@@ -11,7 +11,7 @@ pkgbase = python-ppft
makedepends = python-wheel
depends = python
optdepends = python-dill: for serialization support
- source = ppft-ppft-1.7.6.7.tar.gz::https://github.com/uqfoundation/ppft/archive/ppft-1.7.6.7.tar.gz
- sha512sums = 251017650691e69d875613b1040de3d0cef982450b4858f4f1d1217acbf8d5264bd678d7958710563c0e0971b39bbbfe9f57ab18c089288cd9aeb05179238f8f
+ source = ppft-1.7.6.8.tar.gz::https://github.com/uqfoundation/ppft/archive/1.7.6.8.tar.gz
+ sha512sums = 8f12dfe560eebecbf2fffa6fe0a34989f626b83b8c5b6b0978ee53c0b5f3265215ce33d7c3491b94debae63c535ba39604ee82fb49cde07bed847aa121a3830d
pkgname = python-ppft
diff --git a/PKGBUILD b/PKGBUILD
index 0c4ffcc4b5e9..11149548d312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_base=ppft
pkgname=python-${_base}
pkgdesc="distributed and parallel python"
-pkgver=1.7.6.7
+pkgver=1.7.6.8
pkgrel=1
url="https://github.com/uqfoundation/${_base}"
arch=(any)
@@ -12,23 +12,23 @@ depends=(python)
makedepends=(python-build python-installer python-setuptools python-wheel)
# checkdepends=(python-pytest)
optdepends=('python-dill: for serialization support')
-source=(${_base}-${_base}-${pkgver}.tar.gz::${url}/archive/${_base}-${pkgver}.tar.gz)
-sha512sums=('251017650691e69d875613b1040de3d0cef982450b4858f4f1d1217acbf8d5264bd678d7958710563c0e0971b39bbbfe9f57ab18c089288cd9aeb05179238f8f')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('8f12dfe560eebecbf2fffa6fe0a34989f626b83b8c5b6b0978ee53c0b5f3265215ce33d7c3491b94debae63c535ba39604ee82fb49cde07bed847aa121a3830d')
build() {
- cd ${_base}-${_base}-${pkgver}
+ cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
# check() {
-# cd ${_base}-${_base}-${pkgver}
+# cd ${_base}-${pkgver}
# python -m venv --system-site-packages test-env
# test-env/bin/python -m installer dist/*.whl
# test-env/bin/python -m pytest ${_base}/tests
# }
package() {
- cd ${_base}-${_base}-${pkgver}
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}