summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-31 12:22:52 -0500
committerLuis Martinez2022-03-31 12:22:52 -0500
commita0e4ed905a1943a79c000f5b5fddf1220e0b4c29 (patch)
treebc295ebf4d8aac146536cdbc7739d3892e07fc82
parent3f62b3ad10d19209758a91ea551618a15ace60ef (diff)
downloadaur-python-pscript.tar.gz
update to 0.7.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--releasenotes.rst5
3 files changed, 31 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ede0f309bc1..7d7bd22d8549 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-pscript
pkgdesc = Python to JavaScript compiler
- pkgver = 0.7.6
+ pkgver = 0.7.7
pkgrel = 1
url = https://github.com/flexxui/pscript
+ changelog = releasenotes.rst
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-sphinx
+ makedepends = python-wheel
depends = python
- source = python-pscript-0.7.6.tar.gz::https://github.com/flexxui/pscript/archive/v0.7.6.tar.gz
- sha256sums = 1bc8b5c1319e677837df5659289f14052c84da977c445acde95bf1ada653a6c5
+ source = python-pscript-0.7.7.tar.gz::https://github.com/flexxui/pscript/archive/v0.7.7.tar.gz
+ sha256sums = f02f4bba234aac0088dd674f72de63d16baf4827fbeaf5150515eac90bbf2761
pkgname = python-pscript
diff --git a/PKGBUILD b/PKGBUILD
index f48299e07458..ee9a18087fbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,40 @@
# Contributor: Ronuk Raval <ronuk.raval at gmail dot com>
pkgname=python-pscript
-pkgver=0.7.6
+pkgver=0.7.7
pkgrel=1
pkgdesc='Python to JavaScript compiler'
arch=('any')
url='https://github.com/flexxui/pscript'
license=('BSD')
depends=('python')
-makedepends=('python-setuptools' 'python-sphinx')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-wheel')
changelog=releasenotes.rst
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1bc8b5c1319e677837df5659289f14052c84da977c445acde95bf1ada653a6c5')
+sha256sums=('f02f4bba234aac0088dd674f72de63d16baf4827fbeaf5150515eac90bbf2761')
build() {
cd "pscript-$pkgver"
- python setup.py build
- cd docs
- make man
+ python -m build --wheel --no-isolation
+ make -C docs man
}
package() {
+ export PYTHONHASHSEED=0
cd "pscript-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- install -Dm 644 docs/_build/man/PScript.1 "$pkgdir/usr/share/man/man1/pscript.1"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 docs/_build/man/PScript.1 "$pkgdir/usr/share/man/man1/pscript.1"
+
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/pscript-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim: ts=2 sw=2 et:
diff --git a/releasenotes.rst b/releasenotes.rst
index c98c3c26e285..9a4bc3d3b7d0 100644
--- a/releasenotes.rst
+++ b/releasenotes.rst
@@ -2,6 +2,11 @@
Release notes
-------------
+**v0.7.6** (09-09-2021)
+
+* Fix for with-statement when ``return`` is used in the context.
+* Early support type hints in the code (by Jennifer Taylor).
+
**v0.7.5** (04-01-2021)