summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2018-10-01 20:30:36 -0500
committerSam Whited2018-10-01 20:31:45 -0500
commit7844b74adea1e25ae12ef8fb9a2ddb0b26521af7 (patch)
tree545db228f18f75dd40636dc4ad265f62a8b9e280
parentb436799e15b4c1497590565e80a2fe22e47df80f (diff)
downloadaur-7844b74adea1e25ae12ef8fb9a2ddb0b26521af7.tar.gz
Fix license, deps, arch, and misc cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a587c751b96..e53fcc7de9b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-psycopg2-binary
pkgdesc = Python-PostgreSQL Database Adapter
pkgver = 2.7.5
- pkgrel = 1
+ pkgrel = 2
url = http://initd.org/psycopg/
- arch = any
- license = LGPL,
+ arch = x86_64
+ license = LGPL3
license = ZPL
makedepends = python-setuptools
+ depends = postgresql-libs
depends = python
conflicts = python-psycopg2
source = https://pypi.python.org/packages/source/p/psycopg2-binary/psycopg2-binary-2.7.5.tar.gz
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b53c6dff1211
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.zip
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index bfca188234ea..2972f5a23a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
+# Maintainer: Sam Whited <sam@samwhited.com>
+
pkgname=python-psycopg2-binary
_pkgname=psycopg2-binary
pkgver=2.7.5
-pkgrel=1
-pkgdesc="Python-PostgreSQL Database Adapter"
+pkgrel=2
+pkgdesc='Python-PostgreSQL Database Adapter'
conflicts=('python-psycopg2')
-url=http://initd.org/psycopg/
-arch=('any')
-license=('LGPL', 'ZPL')
-depends=('python')
+url='http://initd.org/psycopg/'
+arch=('x86_64')
+license=(
+ 'LGPL3'
+ 'ZPL'
+)
+depends=(
+ 'postgresql-libs'
+ 'python'
+)
makedepends=('python-setuptools')
source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('c2ac7aa1a144d4e0e613ac7286dae85671e99fe7a1353954d4905629c36b811c')
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- python setup.py install --root="${pkgdir}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
}