summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarti Raudsepp2011-01-19 16:53:25 +0200
committerMarti Raudsepp2011-01-19 16:53:25 +0200
commitb79f09713e95dba987b0329951a927a68fb66448 (patch)
tree4eb9b3887167aa029a852c7ee5d1d39a96e3f4da
downloadaur-python-psycopg2-git.tar.gz
python-psycopg2-git: initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12236613f17d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-psycopg2-git
+ pkgdesc = A PostgreSQL database adapter for the Python programming language.
+ pkgver = 20101209
+ pkgrel = 1
+ url = http://initd.org/projects/psycopg2
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = python2
+ depends = postgresql-libs>=8.4.1
+ provides = python-psycopg2=2.3.2
+ conflicts = python-psycopg2
+ options = !strip
+
+pkgname = python-psycopg2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45f54afe7ed5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Marti Raudsepp <marti@juffo.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+pkgname=python-psycopg2-git
+pkgver=20101209
+pkgrel=1
+pkgdesc="A PostgreSQL database adapter for the Python programming language."
+arch=('i686' 'x86_64')
+url="http://initd.org/projects/psycopg2"
+options=(!strip) # to facilitate debugging of git builds
+license=('LGPL3')
+depends=('python2' 'postgresql-libs>=8.4.1')
+conflicts=('python-psycopg2')
+provides=('python-psycopg2=2.3.2')
+
+_gitroot=git://luna.dndg.it/public/psycopg2.git
+_gitname=psycopg2
+_gitbranch=python2
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname -b $_gitbranch
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+ #git branch $_gitbranch
+
+ export CFLAGS='-ggdb'
+ python2 setup.py install --root="$pkgdir"
+}