summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-03-12 09:22:28 +0100
committerCarl Smedstad2024-03-12 09:43:56 +0100
commit03728c74548907ddc30902d2e154af49cafb0c38 (patch)
tree2733ebeb90bc9a77290a9c47b404aef6b8434763
parent390ee3c2924127ce5bc2972471fd7f19cb63f445 (diff)
downloadaur-python-pyalsaaudio.tar.gz
upgpkg: 0.10.0-3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d75e8c3b810..9ef9938c9a81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-pyalsaaudio
pkgdesc = ALSA wrappers for Python
pkgver = 0.10.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/larsimmisch/pyalsaaudio
arch = x86_64
arch = i686
arch = armv7h
- license = custom:PSF
+ license = LicenseRef-PSF-For-Python-2.4
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
depends = alsa-lib
depends = glibc
- source = python-pyalsaaudio-0.10.0.tar.gz::https://github.com/larsimmisch/pyalsaaudio/archive/refs/tags/0.10.0.tar.gz
- sha256sums = d63465df6bbeda637dcd1b2a9c713f2035b0b890387258db99f28158886303fe
+ source = python-pyalsaaudio-0.10.0.tar.gz::https://github.com/larsimmisch/pyalsaaudio/archive/0.10.0.tar.gz
+ sha256sums = 6d3555fc4a84d969cfe160b651a3744aa479adb74299aa87a026c9283db19fdf
pkgname = python-pyalsaaudio
diff --git a/PKGBUILD b/PKGBUILD
index f9f2546c6b55..a0c2e6b31a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
pkgname=python-pyalsaaudio
-_name=${pkgname#python-}
+_pkgname=${pkgname#python-}
pkgver=0.10.0
-pkgrel=2
+pkgrel=3
pkgdesc="ALSA wrappers for Python"
arch=(x86_64 i686 armv7h)
url="https://github.com/larsimmisch/pyalsaaudio"
-license=(custom:PSF)
+license=(LicenseRef-PSF-For-Python-2.4)
depends=(
alsa-lib
glibc
@@ -22,11 +22,10 @@ makedepends=(
python-setuptools
python-wheel
)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('6d3555fc4a84d969cfe160b651a3744aa479adb74299aa87a026c9283db19fdf')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('d63465df6bbeda637dcd1b2a9c713f2035b0b890387258db99f28158886303fe')
-
-_archive="$_name-$pkgver"
+_archive="$_pkgname-$pkgver"
build() {
cd "$_archive"
@@ -39,5 +38,5 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}