summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-08-01 11:48:47 +0800
committertaotieren2024-08-01 11:48:47 +0800
commit72163a17944ebb62f143d43b63ddb6992506b3e7 (patch)
treeed3e6dbfb5efbb602dda2dac9505801f4d94dd76
parent480edea47c07ea1fc18817a13d9e10921b1a0553 (diff)
downloadaur-python-pydevicetree.tar.gz
update python-pydevicetree
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b81be3a38644..39e44a3c1ee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,16 +2,17 @@ pkgbase = python-pydevicetree
pkgdesc = This is a Python 3 library for parsing, querying, and modifying Devicetree Source v1 files as described in the Devicetree Specification v0.2.
pkgver = 0.0.13
pkgrel = 1
- url = https://github.com/sifive/pydevicetree
+ url = https://pypi.org/project/pydevicetree
arch = any
- license = Apache
+ license = Apache-2.0
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
depends = python
+ depends = python-pyparsing
options = !strip
- source = pydevicetree-0.0.13.zip::https://files.pythonhosted.org/packages/source/p/pydevicetree/pydevicetree-0.0.13.tar.gz
+ source = pydevicetree-0.0.13.tar.gz::https://files.pythonhosted.org/packages/source/p/pydevicetree/pydevicetree-0.0.13.tar.gz
sha256sums = 5700c05df89bad8fd729c11aa6f764a3323bcb3796f13b32481ae34445cfc1b7
pkgname = python-pydevicetree
diff --git a/PKGBUILD b/PKGBUILD
index 37fe6fc3694e..f0c1c2e3fc69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,21 @@ pkgrel=1
epoch=
pkgdesc="This is a Python 3 library for parsing, querying, and modifying Devicetree Source v1 files as described in the Devicetree Specification v0.2."
arch=('any')
-url="https://github.com/sifive/pydevicetree"
-license=('Apache')
+url="https://pypi.org/project/pydevicetree"
+license=('Apache-2.0')
groups=()
-depends=('python')
-makedepends=(python-build
- python-installer
- python-wheel
- python-setuptools)
+_pydeps=(
+ pyparsing)
+depends=(
+ python
+ "${_pydeps[@]/#/python-}")
+_pymakedeps=(
+ build
+ installer
+ wheel
+ setuptools)
+makedepends=(
+ "${_pymakedeps[@]/#/python-}")
checkdepends=()
optdepends=()
provides=()
@@ -24,7 +31,7 @@ backup=()
options=('!strip')
install=
changelog=
-source=("${_name}-${pkgver}.zip::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
noextract=()
sha256sums=('5700c05df89bad8fd729c11aa6f764a3323bcb3796f13b32481ae34445cfc1b7')
#validpgpkeys=()