summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-07-30 11:37:53 +0200
committerMichael Laß2023-07-30 11:41:57 +0200
commitbf57e4583940b272ede0380cc633f6201e7963cb (patch)
tree02d6a1a00bc71c6015dafbabf25022b5b3bc7714
parentb5316eabbae57b6f0c630cd5355f1944d7235ebd (diff)
downloadaur-bf57e4583940b272ede0380cc633f6201e7963cb.tar.gz
Adopt, fix by removing enum-compat from setup.py
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Remove-dependency-on-enum-compat.patch25
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87cf1c1bd14f..25051e78b5ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-pygatt
pkgdesc = Python Bluetooth LE (Low Energy) and GATT Library
pkgver = 4.0.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/peplin/pygatt
arch = any
- license = APACHE
+ license = custom:partly Apache, partly MIT
makedepends = python-setuptools
depends = python-pexpect
depends = python-pyserial
source = https://files.pythonhosted.org/packages/source/p/pygatt/pygatt-4.0.5.tar.gz
+ source = 0001-Remove-dependency-on-enum-compat.patch
sha256sums = 7f4e0ec72f03533a3ef5fdd532f08d30ab7149213495e531d0f6580e9fcb1a7d
+ sha256sums = 1485111d418ac0812751426bbbec76ef56f8d79b7740f41009f7f6cb7f2a1e1a
pkgname = python-pygatt
diff --git a/0001-Remove-dependency-on-enum-compat.patch b/0001-Remove-dependency-on-enum-compat.patch
new file mode 100644
index 000000000000..f4f0e1ae1049
--- /dev/null
+++ b/0001-Remove-dependency-on-enum-compat.patch
@@ -0,0 +1,25 @@
+From ebdee7042daa3262b9ae75b602fe491caae1ee09 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Michael=20La=C3=9F?= <bevan@bi-co.net>
+Date: Sun, 30 Jul 2023 11:40:40 +0200
+Subject: [PATCH] Remove dependency on enum-compat
+
+For Python >=3.4, this package is a no-op.
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2821752..66b55e2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -26,7 +26,6 @@ setup(
+ url='https://github.com/peplin/pygatt',
+ install_requires=[
+ 'pyserial',
+- 'enum-compat'
+ ],
+ setup_requires=[
+ 'coverage >= 3.7.1',
+--
+2.41.0
+
diff --git a/PKGBUILD b/PKGBUILD
index d08511c9363d..7b395e97cc30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
-# Co-contributor: Andrea Pascal <andrea@anodium.net>
+# Maintainer: Michael Lass <bevan@bi-co.net>
+# Contributor: Jose Riha <jose1711 gmail com>
+# Contributor: Andrea Pascal <andrea@anodium.net>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
pkgname=python-pygatt
_module=pygatt
pkgver=4.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="Python Bluetooth LE (Low Energy) and GATT Library"
url="https://github.com/peplin/pygatt"
depends=('python-pexpect' 'python-pyserial')
-license=('APACHE')
+license=('custom:partly Apache, partly MIT')
arch=('any')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('7f4e0ec72f03533a3ef5fdd532f08d30ab7149213495e531d0f6580e9fcb1a7d')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
+ 0001-Remove-dependency-on-enum-compat.patch)
+sha256sums=('7f4e0ec72f03533a3ef5fdd532f08d30ab7149213495e531d0f6580e9fcb1a7d'
+ '1485111d418ac0812751426bbbec76ef56f8d79b7740f41009f7f6cb7f2a1e1a')
+
+prepare() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ patch -p1 < "${srcdir}/0001-Remove-dependency-on-enum-compat.patch"
+}
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -24,7 +35,9 @@ check() {
python setup.py check -m -s
}
-package_python-pygatt() {
+package() {
cd "${srcdir}/${_module}-${pkgver}"
+
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}