summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-10-14 22:40:47 +0200
committerFabioLolix2023-10-14 22:40:47 +0200
commit7b2566923257a0ff3a34c96cd6e52d0dc6c0a355 (patch)
tree1b2281c9cf9945819c83627c6dcd5ef8982a89d4
parente1afedb88e4c3cd10a67c69659cfb77760bd582f (diff)
downloadaur-python-pygccxml.tar.gz
v2.4.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e7b3dac1550..2372c5ebbf6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-pygccxml
pkgdesc = Simple framework to navigate C++ declarations, using Python classes.
- pkgver = 2.2.1
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/gccxml/pygccxml
arch = any
license = Boost
- checkdepends = python-pycodestyle
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
makedepends = python-setuptools
depends = castxml
depends = python
provides = pygccxml
replaces = pygccxml
- source = python-pygccxml-2.2.1.tar.gz::https://github.com/gccxml/pygccxml/archive/v2.2.1.tar.gz
- sha256sums = 9815a12e3bf6b83b2e9d8c88335fb3fa0e2b4067d7fbaaed09c3bf26c6206cc7
+ source = python-pygccxml-2.4.0.tar.gz::https://github.com/gccxml/pygccxml/archive/v2.4.0.tar.gz
+ sha256sums = d59867809f8008ec48a5567a7203bb4c130ff203a8ddd708c945690749723c70
pkgname = python-pygccxml
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d9590d36eab..e6e3b3690fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,23 @@
# Contributor: zarra <zarraxx@gmail.com>
pkgname=python-pygccxml
-pkgver=2.2.1
+pkgver=2.4.0
pkgrel=1
pkgdesc="Simple framework to navigate C++ declarations, using Python classes."
arch=(any)
url="https://github.com/gccxml/pygccxml"
license=(Boost)
depends=(castxml python)
-makedepends=(python-setuptools)
-checkdepends=(python-pycodestyle)
+makedepends=(python-build python-wheel python-installer python-setuptools)
+#checkdepends=(python-pycodestyle)
provides=(pygccxml)
replaces=(pygccxml)
source=("$pkgname-$pkgver.tar.gz::https://github.com/gccxml/pygccxml/archive/v${pkgver}.tar.gz")
-sha256sums=('9815a12e3bf6b83b2e9d8c88335fb3fa0e2b4067d7fbaaed09c3bf26c6206cc7')
+sha256sums=('d59867809f8008ec48a5567a7203bb4c130ff203a8ddd708c945690749723c70')
build() {
cd "${srcdir}/pygccxml-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
#check() {
@@ -30,5 +30,5 @@ build() {
package() {
cd "${srcdir}/pygccxml-${pkgver}"
- python setup.py install --skip-build --optimize=1 --prefix=/usr --root="${pkgdir}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}