summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-12-07 11:18:08 -0500
committerCarlos Aznarán Laos2021-12-07 11:18:08 -0500
commitcae29a5216bdd9707549e34e1b0cec649fda2f5e (patch)
treee56668b31d466ce709fa6e93b5377d5bfd79195f
parent863b70a5f85d9b6fa8cebee45b131e8988a74ca9 (diff)
downloadaur-cae29a5216bdd9707549e34e1b0cec649fda2f5e.tar.gz
Version bump to 7.1.14
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0ce821c2836..2db0c858f905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pygmsh
pkgdesc = Gmsh for Python
- pkgver = 7.1.13
- pkgrel = 2
+ pkgver = 7.1.14
+ pkgrel = 1
url = https://github.com/nschloe/pygmsh
arch = x86_64
license = GPL3
@@ -10,7 +10,7 @@ pkgbase = python-pygmsh
makedepends = python-pip
depends = python-meshio
depends = gmsh
- source = https://github.com/nschloe/pygmsh/archive/v7.1.13.tar.gz
- sha512sums = fab6343cd4801a7b17de33bc53bea23138e6277fb8a6fa42b88b57349613c685906efc23f52d20708ae26e305788b6e330cff4e45a0b17ae6d104fb6bdaf2ad2
+ source = https://github.com/nschloe/pygmsh/archive/v7.1.14.tar.gz
+ sha512sums = 7a7a38e5a54bdd043f7d32bacbf2f936d762fbf88598e052183eed9ad154ed3051ac6d72f4ab5a5c44b8e104dfb04c93639b39fd1335057b31d2d1e7a2c3f507
pkgname = python-pygmsh
diff --git a/PKGBUILD b/PKGBUILD
index 07dfbde24c49..a4b71e073950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
_base=pygmsh
pkgname=python-${_base}
pkgdesc="Gmsh for Python"
-pkgver=7.1.13
-pkgrel=2
+pkgver=7.1.14
+pkgrel=1
arch=('x86_64')
url="https://github.com/nschloe/${_base}"
license=(GPL3)
@@ -12,7 +11,7 @@ depends=(python-meshio gmsh)
makedepends=(python-setuptools python-pip)
checkdepends=(python-pytest-codeblocks) # python-matplotlib
source=(${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('fab6343cd4801a7b17de33bc53bea23138e6277fb8a6fa42b88b57349613c685906efc23f52d20708ae26e305788b6e330cff4e45a0b17ae6d104fb6bdaf2ad2')
+sha512sums=('7a7a38e5a54bdd043f7d32bacbf2f936d762fbf88598e052183eed9ad154ed3051ac6d72f4ab5a5c44b8e104dfb04c93639b39fd1335057b31d2d1e7a2c3f507')
build() {
cd "${_base}-${pkgver}"
@@ -22,7 +21,7 @@ build() {
check() {
cd "${_base}-${pkgver}"
python -c "from setuptools import setup; setup();" install --root="${PWD}/tmp_install" --optimize=1 --skip-build
- PYTHONPATH="${PWD}/tmp_install$(python -c "import site; print(site.getsitepackages()[0])"):/usr/share/gmsh/api/python:${PYTHONPATH}" python -m pytest --codeblocks -k 'not README and not logo and not opencascade_boolean and not opencascade_extrude and not translations' # MPLBACKEND=Agg
+ PYTHONPATH="${PWD}/tmp_install$(python -c "import site; print(site.getsitepackages()[0])"):/usr/share/gmsh/api/python:${PYTHONPATH}" python -m pytest --codeblocks # -k 'not README and not logo and not opencascade_boolean and not opencascade_extrude and not translations' # MPLBACKEND=Agg
}
package() {