summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFenner Macrae2018-04-08 10:38:12 -0700
committerFenner Macrae2018-04-08 10:38:12 -0700
commit1926b43b5ddd5840f461cf9648ed66cb466122e0 (patch)
treecb99a78c2268b8c2f0dfc557f671c83a23181ec9
parent256048cca48c905abca9130acea34450c1bcdab1 (diff)
downloadaur-python-pylint-common.tar.gz
Adopted and fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ef860c7d04b..02cf0bcfcb93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pylint-common
- pkgdesc = Pylint plugin for augmenting and improving error detection and analysis in the standard Python library
- pkgver = 0.2.2
+ pkgdesc = pylint-common is a Pylint plugin to improve Pylint error analysis of the standard Python library
+ pkgver = 0.2.5
pkgrel = 1
url = https://github.com/landscapeio/pylint-common
arch = any
- license = GPL2
+ license = GPL
makedepends = python-setuptools
depends = python
- source = https://github.com/landscapeio/pylint-common/archive/0.2.2.tar.gz
- md5sums = aaa0146cb8ca185849d6a111003c23e8
+ source = https://files.pythonhosted.org/packages/source/p/pylint-common/pylint-common-0.2.5.tar.gz
+ md5sums = 821725a39702815c68558df3059cb176
pkgname = python-pylint-common
diff --git a/PKGBUILD b/PKGBUILD
index 4a5c7c5204b9..97c35a3e9aea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-_pkgname=pylint-common
+pkgbase=python-pylint-common
pkgname=python-pylint-common
-pkgver=0.2.2
+_module='pylint-common'
+pkgver=0.2.5
pkgrel=1
-pkgdesc="Pylint plugin for augmenting and improving error detection and analysis in the standard Python library"
-arch=('any')
+pkgdesc="pylint-common is a Pylint plugin to improve Pylint error analysis of the standard Python library"
url="https://github.com/landscapeio/pylint-common"
-license=('GPL2')
depends=('python')
makedepends=('python-setuptools')
-source=(https://github.com/landscapeio/pylint-common/archive/${pkgver}.tar.gz)
-md5sums=('aaa0146cb8ca185849d6a111003c23e8')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/p/pylint-common/pylint-common-${pkgver}.tar.gz")
+md5sums=('821725a39702815c68558df3059cb176')
build() {
- cd "${_pkgname}-${pkgver}"
-
- python setup.py build
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
-
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et: