summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2024-01-09 14:55:07 -0600
committerkyechou2024-01-09 14:55:07 -0600
commit0ce1f90aff6de2a73108e8bb2476353415dfded3 (patch)
tree3ef5268f15f7a89daebe9cb0afe9719770e05268
parenta88199a9d7f685b35124b0d9e9fbd6ca77b70678 (diff)
downloadaur-python-pypacker.tar.gz
Modernize the build (PEP 517)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25488e9a7858..4926a06c4110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-pypacker
pkgdesc = The fastest and simplest packet manipulation lib for Python
pkgver = 5.4
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/mike01/pypacker
arch = x86_64
license = GPL
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-netifaces
source = https://gitlab.com/mike01/pypacker/-/archive/v5.4/pypacker-v5.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1ad22b19bdf0..50924d2d68e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
pkgname=python-pypacker
pkgver=5.4
-pkgrel=1
+pkgrel=2
pkgdesc="The fastest and simplest packet manipulation lib for Python"
arch=('x86_64')
url="https://gitlab.com/mike01/pypacker"
license=('GPL')
depends=('python' 'python-netifaces')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://gitlab.com/mike01/pypacker/-/archive/v$pkgver/pypacker-v$pkgver.tar.gz")
sha256sums=('aee51eb3c506fee7d7a9055c7f43021666cc272d57c989c3482bc906bf4eb68d')
build() {
cd "$srcdir/pypacker-v$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/pypacker-v$pkgver"
- python setup.py install \
+ python -m installer \
+ --destdir="$pkgdir" \
--prefix=/usr \
- --root="$pkgdir" \
- --optimize=1 \
- --skip-build
+ --compile-bytecode=1 \
+ dist/*.whl
}
# vim: set ts=4 sw=4 et :