summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2022-06-07 04:42:10 +0200
committermorguldir2022-06-07 04:42:10 +0200
commit07e9a4de979b812bb6cbf831b20a9dd616f9078a (patch)
treee05a23bb525a8446816596457403dcbb6dfd3b08
parent8af125e00461c7d39c6e6c25adae8737e02edb66 (diff)
downloadaur-python-pyscroll.tar.gz
Bump version to 2.29, add check()
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0786075cddd..3840149b227c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyscroll
pkgdesc = A generic module for making a fast scrolling image with pygame.
- pkgver = 2.19.3
+ pkgver = 2.29
pkgrel = 1
url = https://github.com/bitcraft/pyscroll
arch = any
@@ -8,8 +8,7 @@ pkgbase = python-pyscroll
makedepends = git
makedepends = python-setuptools
depends = python-pygame
- source = git+https://github.com/bitcraft/pyscroll.git#commit=65a58a7fbe055a5e61dfa518b96fbc2fe8f907a5
+ source = git+https://github.com/bitcraft/pyscroll.git#commit=da826cd81abd48de8929601b07f39d4375b9c33e
md5sums = SKIP
pkgname = python-pyscroll
-
diff --git a/PKGBUILD b/PKGBUILD
index e025cd56b186..140ee9af801a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: MCMic <come@chilliet.eu>
pkgname=python-pyscroll
-pkgver=2.19.3
+pkgver=2.29
pkgrel=1
pkgdesc="A generic module for making a fast scrolling image with pygame."
arch=('any')
@@ -10,10 +10,16 @@ url="https://github.com/bitcraft/pyscroll"
license=(LGPL3)
depends=(python-pygame)
makedepends=(git python-setuptools)
-source=("git+https://github.com/bitcraft/pyscroll.git#commit=65a58a7fbe055a5e61dfa518b96fbc2fe8f907a5")
+_commit=da826cd81abd48de8929601b07f39d4375b9c33e
+source=("git+https://github.com/bitcraft/pyscroll.git#commit=$_commit")
md5sums=(SKIP)
package() {
cd ${srcdir}/pyscroll
python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1
}
+
+check() {
+ cd ${srcdir}/pyscroll
+ python -m unittest tests/pyscroll/test_pyscroll.py
+}