summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-09-08 13:59:52 +0800
committerUniversebenzene2021-09-08 13:59:52 +0800
commit7b7e5ef760c38adc35be8a34c1b1ea6795655b23 (patch)
treeaa1396dd12361acb8f620a777ebbd5d15eaba601
parent71ee7f94452564cdac445c77d9396ad157843fc6 (diff)
downloadaur-python-pysynphot.tar.gz
Update to version 2.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD67
3 files changed, 70 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a59506edb68..3cea8b373855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = python-pysynphot
pkgdesc = Python Synthetic Photometry Utilities
- pkgver = 1.0.1
+ pkgver = 2.0.0
pkgrel = 1
url = http://pysynphot.readthedocs.io
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python-pytest-astropy-header
makedepends = python-setuptools-scm
makedepends = python-astropy
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
- makedepends = graphviz
makedepends = python-beautifulsoup4
- source = https://files.pythonhosted.org/packages/source/p/pysynphot/pysynphot-1.0.1.tar.gz
- md5sums = 7001d298e310c17aa3f5bfe638ed9cf4
+ makedepends = graphviz
+ source = https://files.pythonhosted.org/packages/source/p/pysynphot/pysynphot-2.0.0.tar.gz
+ md5sums = 967a07ffa027ad5684d626a531e7164f
pkgname = python-pysynphot
- depends = python-numpy>=1.9
- depends = python-astropy>=1.1
+ depends = python-astropy
+ depends = python-beautifulsoup4
+ depends = python-six
optdepends = python-matplotlib: Plotting support
optdepends = python-pysynphot-doc: Documentation for PySynphot
diff --git a/.gitignore b/.gitignore
index e896dcd6056d..d4d4c4e9d1e4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,5 @@ pkg
*.part
*.pkg.tar.*
*.log
+*fits
+*.dat
diff --git a/PKGBUILD b/PKGBUILD
index c79288a07ac4..8ac3605f9e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,66 @@
pkgbase=python-pysynphot
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.0.1
+pkgver=2.0.0
pkgrel=1
pkgdesc="Python Synthetic Photometry Utilities"
arch=('i686' 'x86_64')
url="http://pysynphot.readthedocs.io"
license=('BSD')
-makedepends=('python-setuptools-scm' 'python-astropy' 'python-sphinx' 'python-sphinx_rtd_theme' 'graphviz' 'python-beautifulsoup4')
-#checkdepends=('python-pytest-astropy-header')
+makedepends=('python-setuptools-scm' 'python-astropy' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-beautifulsoup4' 'graphviz')
+checkdepends=('python-pytest-astropy-header')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('7001d298e310c17aa3f5bfe638ed9cf4')
+# "http://ssb.stsci.edu/trds/tarfiles/synphot1.tar.gz"
+# "http://ssb.stsci.edu/trds/tarfiles/synphot2.tar.gz"
+# "http://ssb.stsci.edu/trds/tarfiles/synphot3.tar.gz"
+# "http://ssb.stsci.edu/trds/tarfiles/synphot4.tar.gz"
+# "http://ssb.stsci.edu/trds/tarfiles/synphot5.tar.gz"
+# "http://ssb.stsci.edu/trds/tarfiles/synphot6.tar.gz"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/0661429jm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/0661437lm_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/14l1632sm_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/16n1832tm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/39h19082m_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/n9i1408hm_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/r1j2146sm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/rbg2236im_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/rcb1833hm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/t260548pm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/t2605492m_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/t921857im_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/tae17277m_tmt.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/u4c18498m_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/u921351jm_tmg.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/ub31649mm_tmc.fits"
+# "https://ssb.stsci.edu/trds/mtab/OLD_FILES/v8h1925fm_tmc.fits"
+# "https://ssb.stsci.edu/trds/etc/source/qso_fos_001.dat"
+# "https://ssb.stsci.edu/trds/calobs/alpha_lyr_006.fits")
+md5sums=('967a07ffa027ad5684d626a531e7164f')
+# '95f73eb96b7d3fba63f97ff66a6fec8c'
+# 'a36769b70725d7a49adfe302442667ad'
+# 'dd6d78e0e265c0b35bf3dec941f525f2'
+# '97e7c7107db0e3400d123c11804aa6b6'
+# '2bc1ff740c7edf2f0dec4828af1bc359'
+# 'b27c421f98c89c1f494a4def956c1e3a'
+# '7847dc342c24de579ea2f423798bf873'
+# '6267b243634104d02575eb0762ed0dc1'
+# '56a46709366897150e0fa5fe17b50dfb'
+# '28598fda5094b83eaf9febe13bec6d94'
+# '051bd0e84b8e0dd5a57d0c6f982129a0'
+# '02691b456f6d1d1378d3d70317b40b0d'
+# 'af535bc6d2d01fa3c0f4054325a3014c'
+# 'f9f7482455252170dc7d859c0fd9538c'
+# '28945f32aa7e454559769bc0af8ab8af'
+# 'b004f51ffbefab0d9e3c28e9c5a6f17f'
+# 'b960a20bf0328ee4ce561ded1d30989f'
+# '360a53e4ddf34ce558d92a64db0680a3'
+# '95731f9dd60d768e3f25a99b0b2d5620'
+# '27481dae0ca63828f1307dd3b1a9041a'
+# '6d3b85d2b7eb366a79fff0ca497f36ae'
+# '5f68d7398d522b4811d5ba8b8319cd26'
+# '46742a5b57b55baf236f4db88078263b'
+# 'b8d9a22da03fe281cdf5ced04878e71b'
+# '208011793bc36d4f6878b84bc289ed70')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -23,12 +73,15 @@ build() {
#check() {
# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# pytest || warning "Tests failed"
+# mkdir -p ${srcdir}/grp/redcat/trds/{calobs,etc/source,mtab/OLD_FILES}
+# ln -rs ${srcdir}/*.fits ${srcdir}/grp/redcat/trds/mtab/OLD_FILES
+# ln -rs ${srcdir}/*.dat ${srcdir}/grp/redcat/trds/etc/source
+# ln -rs ${srcdir}/alpha_lyr_006.fits ${srcdir}/grp/redcat/trds/calobs
+# PYSYN_CDBS="${srcdir}/grp/redcat/trds" pytest #|| warning "Tests failed"
#}
package_python-pysynphot() {
- depends=('python-numpy>=1.9' 'python-astropy>=1.1')
+ depends=('python-astropy' 'python-beautifulsoup4' 'python-six')
optdepends=('python-matplotlib: Plotting support'
'python-pysynphot-doc: Documentation for PySynphot')
cd ${srcdir}/${_pyname}-${pkgver}