summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-02-28 10:32:09 +0100
committerPhilipp A2019-02-28 10:32:09 +0100
commitafb8946768da5e875ac304e89a7903dc19b343d2 (patch)
tree7346c2f5ea2598ad16a362a374c745a019a70c54
downloadaur-python-pytest-faulthandler.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c529192db88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pytest-faulthandler
+ pkgdesc = pytest plugin that activates the fault handler module for tests
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/pytest-dev/pytest-faulthandler
+ arch = any
+ license = MIT
+ depends = python-pytest
+ noextract = pytest_faulthandler-1.5.0-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/p/pytest-faulthandler/pytest_faulthandler-1.5.0-py2.py3-none-any.whl
+ sha256sums = 461351d67a8f09cd2aa8b343b50ce58c301c8c206fcbf7483ee17c109d6a5ddb
+
+pkgname = python-pytest-faulthandler
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9731419a6e92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31babec4b566
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=pytest-faulthandler
+pkgname=python-$_name
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='pytest plugin that activates the fault handler module for tests'
+arch=(any)
+url="https://github.com/pytest-dev/$_name"
+license=(MIT)
+depends=(python-pytest)
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('461351d67a8f09cd2aa8b343b50ce58c301c8c206fcbf7483ee17c109d6a5ddb')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}