summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Gagnon2017-02-15 11:38:42 -0500
committerDenis Gagnon2017-02-15 11:38:42 -0500
commitb8d7617d1fa73cfdb61e4822af01738d62dd7c60 (patch)
tree884cd5af3e29f8dac139ef17da197b6814550d4a
parent92967df6620a485f33a62099fd34adb868a40c2c (diff)
downloadaur-python-pythonpy.tar.gz
Upgraded to recent version, patch not needed anymore
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--bash_completion.patch12
3 files changed, 11 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 528c2c8554f4..997aacbaa79b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Feb 15 16:37:46 UTC 2017
pkgbase = python-pythonpy
pkgdesc = command line kung fu with python (python -c, with tab completion and shorthand)
- pkgver = 0.4.2
+ pkgver = 0.4.11
pkgrel = 1
url = https://github.com/Russell91/pythonpy
arch = any
@@ -10,10 +12,8 @@ pkgbase = python-pythonpy
optdepends = bash-completion: shell completion support
provides = python-pythonpy
conflicts = python2-pythonpy
- source = https://pypi.python.org/packages/source/p/pythonpy/pythonpy-0.4.2.tar.gz
- source = bash_completion.patch
- sha256sums = 3996d659c8a65e15edc330d2ce377501a44510049bb9acff0972ecf900df4fdb
- sha256sums = c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69
+ source = https://pypi.python.org/packages/source/p/pythonpy/pythonpy-0.4.11.tar.gz
+ sha256sums = 2a8eeace21bb6d1cff3822f612fc5c33cbaaad0933dce84955e594a0bf1ec81a
pkgname = python-pythonpy
diff --git a/PKGBUILD b/PKGBUILD
index 5a999f7d1614..bdfe00500344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: McNoggins <gagnon88 (at) Gmail (dot) com>
pkgname="python-pythonpy"
-pkgver=0.4.2
+pkgver=0.4.11
pkgrel=1
pkgdesc="command line kung fu with python (python -c, with tab completion and shorthand)"
arch=('any')
@@ -11,14 +11,13 @@ makedepends=('python-setuptools')
optdepends=('bash-completion: shell completion support')
provides=('python-pythonpy')
conflicts=('python2-pythonpy')
-source=("https://pypi.python.org/packages/source/p/pythonpy/pythonpy-$pkgver.tar.gz"
- "bash_completion.patch")
-sha256sums=('3996d659c8a65e15edc330d2ce377501a44510049bb9acff0972ecf900df4fdb'
- 'c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69')
+source=("https://pypi.python.org/packages/source/p/pythonpy/pythonpy-$pkgver.tar.gz")
+sha256sums=('2a8eeace21bb6d1cff3822f612fc5c33cbaaad0933dce84955e594a0bf1ec81a')
prepare() {
- cd "$srcdir/pythonpy-$pkgver"
- patch -Np1 -i ../bash_completion.patch
+
+cd "$srcdir/pythonpy-$pkgver"
+
}
package() {
diff --git a/bash_completion.patch b/bash_completion.patch
deleted file mode 100644
index 466e6ecc54ee..000000000000
--- a/bash_completion.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur pythonpy-0.3.7.pristine/setup.py pythonpy-0.3.7.new/setup.py
---- pythonpy-0.3.7.pristine/setup.py 2015-02-09 19:54:50.089070067 -0500
-+++ pythonpy-0.3.7.new/setup.py 2015-02-09 19:55:04.119070198 -0500
-@@ -35,7 +35,7 @@
- ******************************************************************************''')
- target='bash_completion.d'
-
--data_files = [(target, ['pythonpy/pycompletion.sh']),]
-+data_files = [('/etc/bash_completion.d', ['pythonpy/pycompletion.sh']),]
-
- py_entry = 'py%s = pythonpy.__main__:main'
- pycompleter_entry = 'pycompleter%s = pythonpy.pycompleter:main'