summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2024-01-07 10:40:06 +1100
committerchrisjbillington2024-01-07 10:40:06 +1100
commitac07cd22c2f44976571391f423c210ed65c4812d (patch)
treebe2d013d397fb892eaaed23fb8f6c3b6f066ba76
parent52e2143b54044661bd5d6e5df69067e86521dbac (diff)
downloadaur-python-questionary.tar.gz
Remove pinned prompt_toolkit version
Arch doesn't ship that pinned version, so for now we accept the partial breakage. I believe this change suppresses errors when building packages that depend on this one, or something like that.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c42e0b20509..1e42b4bda7c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-questionary
pkgdesc = Python library to build pretty command line user prompts
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/questionary
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 03c9bee4b907..546a0d0ef49a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-questionary
_name=${pkgname#python-}
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python library to build pretty command line user prompts"
license=("MIT")
url="https://pypi.python.org/pypi/$_name"
@@ -12,6 +12,10 @@ source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_nam
sha256sums=('bcce898bf3dbb446ff62830c86c5c6fb9a22a54146f0f5597d3da43b10d8fc8b')
arch=('any')
+prepare() {
+ cd "$_name-$pkgver"
+ sed -i -E "/^prompt_toolkit =/s/,.*$/\"/" pyproject.toml
+}
build() {
cd "$_name-$pkgver"