summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBGameiro2023-05-10 10:20:19 +0200
committerBGameiro2023-05-10 10:20:19 +0200
commit02f8eb2af6ac2e28cc710cc8eea05cbb73089e01 (patch)
tree1adbc32ebd7a5cd89159d00d6246e5092d519b7b
downloadaur-python-radioactivedecay.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38ea7a2503f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-radioactivedecay
+ pkgdesc = A Python package for radioactive decay modelling that supports 1252 radionuclides, decay chains, branching, and metastable states.
+ pkgver = 0.4.17
+ pkgrel = 1
+ url = https://radioactivedecay.github.io/
+ arch = any
+ license = MIT
+ license = custom:ICRP-07, AMDC
+ provides = python-radioactivedecay=0.4.17
+ source = https://files.pythonhosted.org/packages/source/r/radioactivedecay/radioactivedecay-0.4.17.tar.gz
+ sha256sums = dfe474d53f02755a39b40a1bbb189175284f693e0423f64e40878632cf1c0379
+
+pkgname = python-radioactivedecay
+ depends = python>=3.9.0
+ depends = python-matplotlib
+ depends = python-networkx
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-setuptools
+ depends = python-sympy
+ depends = python-importlib_resources>=1.4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cc51d26459f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Bernardo Gameiro <projects@bgameiro.me>
+
+pkgbase='python-radioactivedecay'
+pkgname=('python-radioactivedecay')
+pkgver=0.4.17
+pkgrel=1
+pkgdesc='A Python package for radioactive decay modelling that supports 1252 radionuclides, decay chains, branching, and metastable states.'
+arch=('any')
+url='https://radioactivedecay.github.io/'
+license=('MIT' 'custom:ICRP-07, AMDC')
+source=("https://files.pythonhosted.org/packages/source/r/radioactivedecay/radioactivedecay-$pkgver.tar.gz")
+sha256sums=('dfe474d53f02755a39b40a1bbb189175284f693e0423f64e40878632cf1c0379')
+provides=("python-radioactivedecay=$pkgver")
+
+build() {
+ cd "${srcdir}"/radioactivedecay-$pkgver
+ python setup.py build
+}
+
+package_python-radioactivedecay() {
+ depends=(
+ 'python>=3.9.0'
+ 'python-matplotlib'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-setuptools'
+ 'python-sympy'
+ 'python-importlib_resources>=1.4')
+
+ cd "${srcdir}"/radioactivedecay-$pkgver
+ python setup.py install --root="${pkgdir}" --optimize=1
+} \ No newline at end of file