summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiang Gao2018-01-08 17:34:55 -0500
committerXiang Gao2018-01-08 17:34:55 -0500
commit50991a77013217a7432815b2762360825eeb87b9 (patch)
tree2e91a97a7081bf13e8aaf842624675cee5d21e81
downloadaur-python-rdkit-git.tar.gz
migrate to python3.6
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD41
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab2540680187
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-rdkit-git
+ pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
+ pkgver = 20180107
+ pkgrel = 1
+ url = http://rdkit.org/
+ arch = x86_64
+ license = New BSD License
+ makedepends = git
+ depends = bison
+ depends = boost
+ depends = boost-libs
+ depends = cmake
+ depends = flex
+ depends = python
+ depends = sqlite3
+ depends = python-numpy
+ depends = python-cairocffi
+ depends = python-pillow
+ provides = rdkit
+ source = http://www.inchi-trust.org/download/104/INCHI-1-API.zip
+ source = git+https://github.com/rdkit/rdkit.git
+ md5sums = 8447bf108af12fe66eecba41bbc89918
+ md5sums = SKIP
+
+pkgname = python-rdkit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bb45f1a37b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Xiang Gao <qasdfgtyuiop@gmail.com>
+# Contributor: Samo Turk <samo.turk@gmail.com>
+pkgname=python-rdkit-git
+pkgver=20180107
+pkgrel=1
+pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
+arch=("x86_64")
+url="http://rdkit.org/"
+license=('New BSD License')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python' 'sqlite3' 'python-numpy' 'python-cairocffi' 'python-pillow')
+makedepends=('git')
+source=("http://www.inchi-trust.org/download/104/INCHI-1-API.zip"
+ "git+https://github.com/rdkit/rdkit.git")
+md5sums=('8447bf108af12fe66eecba41bbc89918' 'SKIP')
+provides=('rdkit')
+
+pkgver() {
+ cd ${srcdir}/rdkit
+ git log -1 --format=%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd ${srcdir}
+ cp INCHI-1-API/INCHI_API/inchi_dll/* rdkit/External/INCHI-API/
+ cmake rdkit \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DRDK_INSTALL_INTREE=0 \
+ -DRDK_BUILD_THREADSAFE_SSS=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_LIBRARY=/usr/lib/python3.6/config-3.6m-x86_64-linux-gnu/libpython3.6m.a \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.6m/ \
+ -DPYTHON_EXECUTABLE=/usr/bin/python
+ make -j$(nproc)
+}
+
+
+package() {
+ echo "Making package.."
+ cd ${srcdir}
+ make DESTDIR=${pkgdir} install
+}