summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2020-01-14 20:01:14 -0800
committerDonald Webster2020-01-14 20:01:45 -0800
commitaace661fa9b768b16c4fd1d2231622fb101ed0ad (patch)
tree92055971fe29dbc19af111b52768f240992c448d
parent15934a06c8558d4adf72f14f8ad2c667cf37f8b5 (diff)
downloadaur-aace661fa9b768b16c4fd1d2231622fb101ed0ad.tar.gz
Add patch from issue #20 to solve Python 4.8.1 problem.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--rebulk.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c5b247c6861..a0935a1f5c2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-rebulk
pkgdesc = Define simple search patterns in bulk to perform advanced matching on any string.
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Toilal/rebulk
arch = any
license = MIT
@@ -9,7 +9,9 @@ pkgbase = python-rebulk
makedepends = python2-setuptools
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/r/rebulk/rebulk-2.0.0.tar.gz
+ source = rebulk.patch
sha512sums = e42bc73645eaa33ee321d69d5091c0a11e47ade0b2b48ba78b8b682e327f0608bb4345e7be7e51551b672bbfd6de490bc563e12344da30be6900b5860b9047ab
+ sha512sums = 1fa8131d60b6b2217ad1a9b9eed8b359e9e1f4bca6c8c59ef28f06f732ebb589d5d728dce8cf9847eb32172c6fea1967d3e65470790e05657031bf8724fc3f41
pkgname = python-rebulk
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 67b5f0b69955..77ab776ffe19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('python-rebulk' 'python2-rebulk')
_name=${pkgname#python-}
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Define simple search patterns in bulk to perform advanced matching on any string. "
arch=("any")
url="https://github.com/Toilal/rebulk"
@@ -12,11 +12,14 @@ license=('MIT')
makedepends=('python-setuptools'
'python2-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('e42bc73645eaa33ee321d69d5091c0a11e47ade0b2b48ba78b8b682e327f0608bb4345e7be7e51551b672bbfd6de490bc563e12344da30be6900b5860b9047ab')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ 'rebulk.patch')
+sha512sums=('e42bc73645eaa33ee321d69d5091c0a11e47ade0b2b48ba78b8b682e327f0608bb4345e7be7e51551b672bbfd6de490bc563e12344da30be6900b5860b9047ab'
+ '1fa8131d60b6b2217ad1a9b9eed8b359e9e1f4bca6c8c59ef28f06f732ebb589d5d728dce8cf9847eb32172c6fea1967d3e65470790e05657031bf8724fc3f41')
prepare() {
cp -a "rebulk-${pkgver}"{,-py2}
+ patch "${srcdir}/${_name}-${pkgver}/rebulk/loose.py" "${srcdir}/rebulk.patch"
}
check() {
diff --git a/rebulk.patch b/rebulk.patch
new file mode 100644
index 000000000000..9793452e81c1
--- /dev/null
+++ b/rebulk.patch
@@ -0,0 +1,11 @@
+diff --git a/rebulk/loose.py b/rebulk/loose.py
+index 5e747a8..e92d594 100644
+--- a/rebulk/loose.py
++++ b/rebulk/loose.py
+@@ -56,7 +56,7 @@ def call(function, *args, **kwargs):
+ :rtype: object
+ """
+ func = constructor_args if isclass(function) else function_args
+- call_args, call_kwargs = func(function, *args, **kwargs)
++ call_args, call_kwargs = func(function, *args, ignore_unused=True, **kwargs)
+ return function(*call_args, **call_kwargs)