summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2020-05-01 18:49:03 -0700
committerDonald Webster2020-05-01 18:49:03 -0700
commitbd956f507d9440ab8c9e63375ab5b35b5547a65a (patch)
treed521fbc5bd270ccd9da39b2b6becdc4953615066
parent1bb64fdb2cde07a1e78a2f2b56129d7dd7c419ea (diff)
downloadaur-bd956f507d9440ab8c9e63375ab5b35b5547a65a.tar.gz
Patch isn't needed anymore...
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--rebulk.patch11
3 files changed, 4 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97cfb23aba0e..582fb15fbf4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-rebulk
pkgdesc = Define simple search patterns in bulk to perform advanced matching on any string.
pkgver = 2.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Toilal/rebulk
arch = any
license = MIT
@@ -9,9 +9,7 @@ pkgbase = python-rebulk
makedepends = python2-setuptools
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/r/rebulk/rebulk-2.0.1.tar.gz
- source = rebulk.patch
sha512sums = 7d453b7ba952994dec3258aa95a3f6090e6f8afb5a674c1b5e54e036f41022b887d3d65d21f2023ae6e2596cce3baf52d33fc23708498a4f0aef26d3594c8289
- sha512sums = 1fa8131d60b6b2217ad1a9b9eed8b359e9e1f4bca6c8c59ef28f06f732ebb589d5d728dce8cf9847eb32172c6fea1967d3e65470790e05657031bf8724fc3f41
pkgname = python-rebulk
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index a2d74fbb8a4e..0c2e439bf7f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('python-rebulk' 'python2-rebulk')
_name=${pkgname#python-}
pkgver=2.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Define simple search patterns in bulk to perform advanced matching on any string. "
arch=("any")
url="https://github.com/Toilal/rebulk"
@@ -12,14 +12,11 @@ license=('MIT')
makedepends=('python-setuptools'
'python2-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- 'rebulk.patch')
-sha512sums=('7d453b7ba952994dec3258aa95a3f6090e6f8afb5a674c1b5e54e036f41022b887d3d65d21f2023ae6e2596cce3baf52d33fc23708498a4f0aef26d3594c8289'
- '1fa8131d60b6b2217ad1a9b9eed8b359e9e1f4bca6c8c59ef28f06f732ebb589d5d728dce8cf9847eb32172c6fea1967d3e65470790e05657031bf8724fc3f41')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('7d453b7ba952994dec3258aa95a3f6090e6f8afb5a674c1b5e54e036f41022b887d3d65d21f2023ae6e2596cce3baf52d33fc23708498a4f0aef26d3594c8289')
prepare() {
cp -a "rebulk-${pkgver}"{,-py2}
- patch "${srcdir}/${_name}-${pkgver}/rebulk/loose.py" "${srcdir}/rebulk.patch"
}
check() {
diff --git a/rebulk.patch b/rebulk.patch
deleted file mode 100644
index 9793452e81c1..000000000000
--- a/rebulk.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/rebulk/loose.py b/rebulk/loose.py
-index 5e747a8..e92d594 100644
---- a/rebulk/loose.py
-+++ b/rebulk/loose.py
-@@ -56,7 +56,7 @@ def call(function, *args, **kwargs):
- :rtype: object
- """
- func = constructor_args if isclass(function) else function_args
-- call_args, call_kwargs = func(function, *args, **kwargs)
-+ call_args, call_kwargs = func(function, *args, ignore_unused=True, **kwargs)
- return function(*call_args, **call_kwargs)