summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-06-04 19:53:15 +0800
committerUniversebenzene2022-06-04 19:53:15 +0800
commit13c55b3fce8297ad06cfcb0450be11ef53dce873 (patch)
tree5c3748f4ee416fae53effbe8c31de2b979212b9f
downloadaur-python-runnotebook.tar.gz
Initial import 0.3.1
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD69
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0550208ddf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-runnotebook
+ pkgdesc = IPython notebook sphinx extensions
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/ngoldbaum/RunNotebook
+ arch = any
+ license = BSD
+ checkdepends = python-nose
+ checkdepends = jupyter-nbformat
+ checkdepends = jupyter-nbconvert
+ checkdepends = python-docutils
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/R/RunNotebook/RunNotebook-0.3.1.tar.gz
+ source = https://raw.githubusercontent.com/ngoldbaum/RunNotebook/master/LICENSE
+ md5sums = 67ddf123b72f97369831ba684a426962
+ md5sums = SKIP
+
+pkgname = python-runnotebook
+ depends = python-sphinx
+ depends = jupyter-notebook
+ depends = python-qtconsole
+ depends = jupyter_console
+ depends = jupyter-nbconvert
+ depends = python-ipykernel
+ depends = python-ipywidgets
+ depends = jupyter-nbformat
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..06a3cebf3615
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar*
+*.log
+LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c27ee0d6642
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
+pkgbase=python-runnotebook
+_pname=${pkgbase#python-}
+_pyname=RunNotebook
+pkgname=("python-${_pname}")
+#"python-${_pname}-example")
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="IPython notebook sphinx extensions"
+arch=('any')
+url="https://github.com/ngoldbaum/RunNotebook"
+license=('BSD')
+makedepends=('python-setuptools')
+# 'python-wheel'
+# 'python-build'
+# 'python-installer'
+# 'python-sphinx')
+checkdepends=('python-nose'
+ 'jupyter-nbformat'
+ 'jupyter-nbconvert'
+ 'python-docutils')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/ngoldbaum/RunNotebook/master/LICENSE")
+md5sums=('67ddf123b72f97369831ba684a426962'
+ 'SKIP')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+# python -m build --wheel --no-isolation
+ python setup.py build
+
+# msg "Building Examples"
+# cd ${srcdir}/${_pyname}-${pkgver}/example
+# PYTHONPATH="../build/lib" make html
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ nosetests
+}
+
+package_python-runnotebook() {
+ depends=('python-sphinx'
+ 'jupyter-notebook'
+ 'python-qtconsole'
+ 'jupyter_console'
+ 'jupyter-nbconvert'
+ 'python-ipykernel'
+ 'python-ipywidgets'
+ 'jupyter-nbformat')
+ cd ${srcdir}/${_pyname}-${pkgver}
+# optdepends=('python-runnotebook-example: example documentation')
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ${srcdir}/LICENSE
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+# python -m installer --destdir="${pkgdir}" dist/*.whl
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+#package_python-runnotebook-example() {
+# pkgdesc="RunNotebook example documentation"
+# cd ${srcdir}/${_pyname}-${pkgver}/example/build
+#
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}