summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-03-04 15:32:29 +0100
committerJulien Nicoulaud2019-03-04 15:32:29 +0100
commit16ce93377ef5e39154c0b8d333947f0b9af15f6c (patch)
treea9b9efaefa80ec64e0308b45fa6e000d3b5ec5a6
parent44017ad517b133c33768f8794165dc34aaeb4e71 (diff)
downloadaur-python-rx.tar.gz
Use tarball for source, make it a split package
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
3 files changed, 33 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94626305c5c3..fbd4c7edb161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = python-rx
pkgdesc = The Reactive Extensions for Python (RxPY)
pkgver = 1.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://reactivex.io
arch = any
license = apache
+ makedepends = python
+ makedepends = python2
makedepends = python-setuptools
- source = rx::git+https://github.com/ReactiveX/RxPY.git#tag=1.6.1
- md5sums = SKIP
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/R/Rx/Rx-1.6.1.tar.gz
+ sha512sums = 8602b5175c058e855ac4b67d8feed435f93632da2f4033fe0db54fcbb012a702786b29f97fe3fd641f054c3a61478dccac21c614b5708f7bfb0b986c9951e6a9
pkgname = python-rx
+pkgname = python2-rx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eab14e54627
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
+/*.zst
+/*.swp
diff --git a/PKGBUILD b/PKGBUILD
index 577885e4fb19..204bb86cb779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
# Maintainer: Ilya Elenskiy <elenskiy.ilya[@]gmail[.]com>
+# Maintainer: Julien Nicoulaud <julien DOT nicoulaud AT gmail DOT com>
+_pypiname=Rx
+_pkgname=rx
+pkgbase="python-${_pkgname}"
+pkgname=("python-${_pkgname}" "python2-${_pkgname}")
pkgname=python-rx
-_name=rx
pkgver=1.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="The Reactive Extensions for Python (RxPY)"
arch=('any')
url='http://reactivex.io'
license=('apache')
-makedepends=( 'python-setuptools' )
-source=("rx::git+https://github.com/ReactiveX/RxPY.git#tag=${pkgver}")
-md5sums=('SKIP')
+makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
+source=("https://files.pythonhosted.org/packages/source/R/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+sha512sums=('8602b5175c058e855ac4b67d8feed435f93632da2f4033fe0db54fcbb012a702786b29f97fe3fd641f054c3a61478dccac21c614b5708f7bfb0b986c9951e6a9')
+prepare() {
+ cp -a ${_pypiname}-${pkgver}{,-py2}
+}
-build() {
- cd "${srcdir}/${_name}"
- python setup.py build
+package_python-rx() {
+ cd ${_pypiname}-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
}
-package() {
- cd "${srcdir}/${_name}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+package_python2-rx() {
+ cd ${_pypiname}-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
}
+