summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrr2018-05-17 22:53:47 +0300
committerptrr2018-05-17 22:53:47 +0300
commitb5b9ff6f90d811ac4116364bc8e099835fc6e6c9 (patch)
tree8edf0e60584570291ca50c0d0a2e1eecb5fa94b8
parentff066443f458dbcb8de7c862fdc0ded0aaf6a46f (diff)
downloadaur-b5b9ff6f90d811ac4116364bc8e099835fc6e6c9.tar.gz
Remove Python2 references
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD47
2 files changed, 4 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a6a2129f3fe..ef6b25c61585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,10 +25,3 @@ pkgname = python-scipy-openblas
provides = python-scipy
conflicts = python-scipy
-pkgname = python2-scipy-openblas
- depends = python2-numpy-openblas
- depends = openblas-lapack
- optdepends = python2-pillow: for image saving module
- provides = python2-scipy
- conflicts = python2-scipy
-
diff --git a/PKGBUILD b/PKGBUILD
index 340c246716d9..76f7784de605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Bodor Dávid Gábor <david.gabor.bodor@gmail.com>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
-pkgname=("python-scipy-openblas" "python2-scipy-openblas")
+pkgname="python-scipy-openblas"
pkgver=1.1.0
pkgrel=1
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
@@ -27,22 +27,8 @@ build() {
export Atlas=None
export LDFLAGS="$LDFLAGS -shared"
- # 2 builds
- cp -r scipy-${pkgver} scipy-${pkgver}-py2
-
- # build for python3
cd scipy-${pkgver}
- python3 setup.py config_fc --fcompiler=gnu95 build
-
- # build for python2
- cd ../scipy-${pkgver}-py2
-
- for file in $(find . -name '*.py' -print); do
- sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
- sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
- done
-
- python2 setup.py config_fc --fcompiler=gnu95 build
+ python setup.py config_fc --fcompiler=gnu95 build
}
check() {
@@ -54,18 +40,11 @@ check() {
export LDFLAGS="$LDFLAGS -shared"
cd ${srcdir}/scipy-${pkgver}
- python3 setup.py config_fc --fcompiler=gnu95 install \
+ python setup.py config_fc --fcompiler=gnu95 install \
--prefix=/usr --root=${srcdir}/test --optimize=1
export PYTHONPATH=${srcdir}/test/usr/lib/python3.6/site-packages
cd ${srcdir}
python -c "from scipy import test; test('full')"
-
- cd ${srcdir}/scipy-${pkgver}-py2
- python2 setup.py config_fc --fcompiler=gnu95 install \
- --prefix=/usr --root=${srcdir}/test --optimize=1
- export PYTHONPATH=${srcdir}/test/usr/lib/python2.7/site-packages
- cd ${srcdir}
- python2 -c "from scipy import test; test('full')"
}
package_python-scipy-openblas() {
@@ -78,27 +57,9 @@ package_python-scipy-openblas() {
export Atlas=None
export LDFLAGS="$LDFLAGS -shared"
- python3 setup.py config_fc --fcompiler=gnu95 install \
+ python setup.py config_fc --fcompiler=gnu95 install \
--prefix=/usr --root=${pkgdir} --optimize=1
install -Dm644 LICENSE.txt \
"${pkgdir}/usr/share/licenses/python-scipy/LICENSE"
}
-
-package_python2-scipy-openblas() {
- depends=('python2-numpy-openblas' 'openblas-lapack')
- optdepends=('python2-pillow: for image saving module')
- provides=('python2-scipy')
- conflicts=('python2-scipy')
-
- cd scipy-${pkgver}-py2
- export Atlas=None
- export LDFLAGS="$LDFLAGS -shared"
-
- python2 setup.py config_fc --fcompiler=gnu95 install \
- --prefix=/usr --root=${pkgdir} --optimize=1
-
- install -Dm644 LICENSE.txt \
- "${pkgdir}/usr/share/licenses/python2-scipy/LICENSE"
-}
-