summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2017-04-12 16:57:23 +1000
committerAndy Botting2017-04-12 16:57:23 +1000
commit0d434638f68120cb573388756b3797899650885a (patch)
treedc06d3a253014502c28d6460e1c6fe583975de86
parent94d33a75b5982eb173d6545297407a95f29828e7 (diff)
downloadaur-0d434638f68120cb573388756b3797899650885a.tar.gz
Update to v1.19.0-2
-rw-r--r--.SRCINFO124
-rw-r--r--PKGBUILD84
2 files changed, 141 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61e981e9a0d6..4b4f999d1e46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,59 +1,99 @@
pkgbase = python-shade
pkgdesc = Simple client library for interacting with OpenStack clouds
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = http://docs.openstack.org/infra/shade
arch = any
license = Apache
+ checkdepends = python-pbr
+ checkdepends = python2-pbr
+ checkdepends = python-munch
+ checkdepends = python2-munch
+ checkdepends = python2-decorator
+ checkdepends = python-decorator
+ checkdepends = python-jmespath
+ checkdepends = python2-jmespath
+ checkdepends = python-jsonpatch
+ checkdepends = python2-jsonpatch
+ checkdepends = python2-ipaddress
+ checkdepends = python2-futures
+ checkdepends = python-os-client-config
+ checkdepends = python2-os-client-config
+ checkdepends = python-requestsexceptions
+ checkdepends = python2-requestsexceptions
+ checkdepends = python-six
+ checkdepends = python2-six
+ checkdepends = python-keystoneauth1
+ checkdepends = python2-keystoneauth1
+ checkdepends = python-netifaces
+ checkdepends = python2-netifaces
+ checkdepends = python-novaclient
+ checkdepends = python2-novaclient
+ checkdepends = python-keystoneclient
+ checkdepends = python2-keystoneclient
+ checkdepends = python-cinderclient
+ checkdepends = python2-cinderclient
+ checkdepends = python-neutronclient
+ checkdepends = python2-neutronclient
+ checkdepends = python-ironicclient
+ checkdepends = python2-ironicclient
+ checkdepends = python-designateclient
+ checkdepends = python2-designateclient
+ checkdepends = python-dogpile.cache
+ checkdepends = python2-dogpile.cache
+ checkdepends = python-fixtures
+ checkdepends = python2-fixtures
+ checkdepends = python-mock
+ checkdepends = python2-mock
+ checkdepends = python-subunit
+ checkdepends = python2-subunit
+ checkdepends = python-requests-mock
+ checkdepends = python2-requests-mock
+ checkdepends = python-testtools
+ checkdepends = python2-testtools
+ checkdepends = python-oslotest
+ checkdepends = python2-oslotest
+ makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
source = git+https://git.openstack.org/openstack-infra/shade#tag=1.19.0
sha256sums = SKIP
pkgname = python-shade
- depends = python-dogpile.cache
- depends = python-magnumclient
- depends = python-heatclient
- depends = python-swiftclient
- depends = python-ironicclient
- depends = python-troveclient
- depends = python-neutronclient
- depends = python-cinderclient
- depends = python-glanceclient
- depends = python-keystoneclient
- depends = python-novaclient
- depends = python-netifaces
- depends = python-keystoneauth1
- depends = python-six
- depends = python-requestsexceptions
- depends = python-os-client-config
- depends = python-jsonpatch
- depends = python-jmespath
- depends = python-decorator
- depends = python-munch
depends = python-pbr
+ depends = python2-decorator
+ depends = python-jmespath
+ depends = python-jsonpatch
+ depends = python-os-client-config
+ depends = python-requestsexceptions
+ depends = python-six
+ depends = python-keystoneauth1
+ depends = python-netifaces
+ depends = python-novaclient
+ depends = python-keystoneclient
+ depends = python-cinderclient
+ depends = python-neutronclient
+ depends = python-ironicclient
+ depends = python-designateclient
+ depends = python-dogpile.cache
pkgname = python2-shade
- depends = python-dogpile.cache
- depends = python-magnumclient
- depends = python-heatclient
- depends = python-swiftclient
- depends = python-ironicclient
- depends = python-troveclient
- depends = python-neutronclient
- depends = python-cinderclient
- depends = python-glanceclient
- depends = python-keystoneclient
- depends = python-novaclient
- depends = python-netifaces
- depends = python-keystoneauth1
- depends = python-six
- depends = python-requestsexceptions
- depends = python-os-client-config
+ depends = python2-pbr
+ depends = python2-decorator
+ depends = python2-jmespath
+ depends = python2-jsonpatch
depends = python2-ipaddress
- depends = python-jsonpatch
- depends = python-jmespath
- depends = python-decorator
- depends = python-munch
- depends = python-pbr
+ depends = python2-os-client-config
+ depends = python2-requestsexceptions
+ depends = python2-six
+ depends = python2-futures
+ depends = python2-keystoneauth1
+ depends = python2-netifaces
+ depends = python2-novaclient
+ depends = python2-keystoneclient
+ depends = python2-cinderclient
+ depends = python2-neutronclient
+ depends = python2-ironicclient
+ depends = python2-designateclient
+ depends = python2-dogpile.cache
diff --git a/PKGBUILD b/PKGBUILD
index 1efa527975fa..ca211697b21b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,83 @@
# Maintainer: Andy Botting <andy@andybotting.com>
+_module='shade'
pkgname=('python-shade' 'python2-shade')
pkgver='1.19.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Simple client library for interacting with OpenStack clouds'
arch=('any')
-url='http://docs.openstack.org/infra/shade'
+url="http://docs.openstack.org/infra/${_module}"
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("git+https://git.openstack.org/openstack-infra/shade#tag=$pkgver")
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+checkdepends=('python-pbr' 'python2-pbr'
+ 'python-munch' 'python2-munch'
+ 'python2-decorator' 'python-decorator'
+ 'python-jmespath' 'python2-jmespath'
+ 'python-jsonpatch' 'python2-jsonpatch'
+ 'python2-ipaddress' 'python2-futures'
+ 'python-os-client-config' 'python2-os-client-config'
+ 'python-requestsexceptions' 'python2-requestsexceptions'
+ 'python-six' 'python2-six'
+ 'python-keystoneauth1' 'python2-keystoneauth1'
+ 'python-netifaces' 'python2-netifaces'
+ 'python-novaclient' 'python2-novaclient'
+ 'python-keystoneclient' 'python2-keystoneclient'
+ 'python-cinderclient' 'python2-cinderclient'
+ 'python-neutronclient' 'python2-neutronclient'
+ 'python-ironicclient' 'python2-ironicclient'
+ 'python-designateclient' 'python2-designateclient'
+ 'python-dogpile.cache' 'python2-dogpile.cache'
+ 'python-fixtures' 'python2-fixtures'
+ 'python-mock' 'python2-mock'
+ 'python-subunit' 'python2-subunit'
+ 'python-requests-mock' 'python2-requests-mock'
+ 'python-testtools' 'python2-testtools'
+ 'python-oslotest' 'python2-oslotest')
+source=("git+https://git.openstack.org/openstack-infra/${_module}#tag=${pkgver}")
sha256sums=('SKIP')
prepare() {
- cp -a shade{,-py2}
-}
-
+ cp -a "${srcdir}/${_module}"{,-py2}
+}
+
build() {
- cd "$srcdir"/shade
+ cd "${srcdir}/${_module}"
+ # Fix test function name for Python 3
+ sed -i 's/assertItemsEqual/assertCountEqual/g' shade/tests/unit/*.py
python setup.py build
- cd "$srcdir"/shade-py2
+ cd "${srcdir}/${_module}-py2"
python2 setup.py build
}
+check() {
+ cd "${srcdir}/${_module}"
+ python setup.py testr
+
+ cd "${srcdir}/${_module}-py2"
+ PYTHON=python2 python2 setup.py testr
+}
+
package_python-shade(){
- depends=('python-dogpile.cache' 'python-magnumclient' 'python-heatclient'
- 'python-swiftclient' 'python-ironicclient' 'python-troveclient'
- 'python-neutronclient' 'python-cinderclient' 'python-glanceclient'
- 'python-keystoneclient' 'python-novaclient' 'python-netifaces'
- 'python-keystoneauth1' 'python-six' 'python-requestsexceptions'
- 'python-os-client-config' 'python-jsonpatch' 'python-jmespath'
- 'python-decorator' 'python-munch' 'python-pbr')
- cd "${srcdir}/shade"
+ depends=('python-pbr' 'python2-decorator' 'python-jmespath'
+ 'python-jsonpatch' 'python-os-client-config'
+ 'python-requestsexceptions' 'python-six' 'python-keystoneauth1'
+ 'python-netifaces' 'python-novaclient' 'python-keystoneclient'
+ 'python-cinderclient' 'python-neutronclient' 'python-ironicclient'
+ 'python-designateclient' 'python-dogpile.cache')
+ cd "${srcdir}/${_module}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-shade() {
- depends=('python-dogpile.cache' 'python-magnumclient' 'python-heatclient'
- 'python-swiftclient' 'python-ironicclient' 'python-troveclient'
- 'python-neutronclient' 'python-cinderclient' 'python-glanceclient'
- 'python-keystoneclient' 'python-novaclient' 'python-netifaces'
- 'python-keystoneauth1' 'python-six' 'python-requestsexceptions'
- 'python-os-client-config' 'python2-ipaddress' 'python-jsonpatch'
- 'python-jmespath' 'python-decorator' 'python-munch' 'python-pbr')
- cd "${srcdir}/shade-py2"
+ depends=('python2-pbr' 'python2-decorator' 'python2-jmespath'
+ 'python2-jsonpatch' 'python2-ipaddress' 'python2-os-client-config'
+ 'python2-requestsexceptions' 'python2-six' 'python2-futures'
+ 'python2-keystoneauth1' 'python2-netifaces' 'python2-novaclient'
+ 'python2-keystoneclient' 'python2-cinderclient'
+ 'python2-neutronclient' 'python2-ironicclient'
+ 'python2-designateclient' 'python2-dogpile.cache')
+ cd "${srcdir}/${_module}-py2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}"/usr/bin/shade-inventory{,2}
}